Wordbook Hilfe

Inhalt

Diese Hilfe ist gültig für die folgenden Wordbook-Versionen: Wordbook (inkl. Demo-Version und Viewer-Version)
Für die Demo-Version und die Viewer-Version sind nicht alle Funktionen verfügbar, die in dieser Hilfe beschrieben sind.

Einführung

Neue Funktionen

Erste Schritte

Hauptansicht

Stichworte eingeben (Wörterbücher)

Stichworte eingeben (Enzyklopädien, Weblog)

Untergeordnete Stichworte eingeben

Programm-Beschreibung

Beispiele

Vertrieb und Support

Copyright Wordbook Software 1998-2023


Einführung

In diesem Abschnitt finden Sie eine kurze Übersicht über Wordbook.

Wordbook ist ein leistungsfähiges Programm zur Erstellung von drei verschiedenen Typen von Projekten:

1. Wörterbüchern
Mit Wordbook können sowohl elektronische Wörterbücher als auch herkömmliche, papiergebundene Wörterbücher in vielen Sprachen erstellt werden.

2. Enzyklopädien, Lexika, Linksammlungen, usw.
Mit Wordbook können Enzyklopädien, Lexika und Linksammlungen (oder andere ähnliche Projekte) erstellt werden, die Texte, Bilder, Audio-Dateien, Links zu Internet-Seiten enthalten.

3. Weblogs ("Blogs")
Mit Wordbook können Weblogs (oder andere ähnliche Projekte, wie z.B. Tagebücher) erstellt werden.

Zur Erfüllung der damit verbundenen Aufgaben verfügt Wordbook über vielfältige Funktionen und Leistungsmerkmale:

Wörterbücher:

- Anlegen von Wörterbüchern in vielen Sprachen (Schriften sind für jede Übersetzungsrichtung frei wählbar)
- gleichzeitiges Öffnen und Bearbeiten von mehreren Wörterbüchern
- gemeinsame Funktionen über mehrere Wörterbücher hinweg (z.B. Drucken, Export, Ansicht)
- Stichworten können beliebig viele Entsprechungen, Eigenschaften, Eigenschaftsausprägungen und Sachgebiete zugeordnet werden
- Entsprechungen können beliebig viele Eigenschaften, Eigenschaftsausprägungen, Sachgebiete, Beispiele und Beispielübersetzungen zugeordnet werden
- Anlegen untergeordneter Stichworte möglich (für Wortfamilien,...)
- Eingabe von Lautschrift
- Vertonung von Stichworten (Soundkarte+Mikrofon erforderlich)
- Zuordnen von Bildern
- Anlegen selbst definierter Eigenschaften und Sachgebiete
- Automatisches Zuordnen von Eigenschaften und Sachgebieten
- Automatisiertes und manuelles Aufbauen von Querverweisen
- differenzierte Navigation
- gezielte Suche nach Stichworten, Entsprechungen, Beispielen, Beispielübersetzungen
- spezielle Filterfunktionen
- Anlegen von Regeln, mit denen Begriffsvarianten (Konjugationsformen usw.) einfach abgebildet werden können
- Wörterbuch-Statistik
- Vokabeltraining
- unterschiedliche, editierbare Sichten
- verschiedene Druckmöglichkeiten, inklusive skaliertem Ausdruck von Bildern
- Standardberichte
- Einstellung spezieller Druckschriften
- Import von mit Wordbook erstellten Wörterbüchern
- Import aus Dateien bzw. anderen Datenbanken
- Automatisches Zuordnen von Sachgebieten/Eigenschaften beim Datenimport
- Export in andere Formate
- Ausgabe im XML-Format
- Umkehren der Übersetzungsrichtung kompletter Wörterbücher
- Generieren von HTML-Seiten zur Bereitstellung im World Wide Web
- Cascading Stylesheets (CSS) zur formatierten HTML-Ausgabe
- Erstellen einer Steuerdatei zur Aufbereitung des Wörterbuchs mit einem Textverarbeitungsprogramm
- verschiedene Formatvorlagen zur Aufbereitung des Wörterbuchs mit einem Textverarbeitungsprogramm
- Anzeige und Verwaltung mehrerer Fenster durch MDI-Technik

Enzyklopädien/Linksammlungen:

- Stichworten können beliebig viele Entsprechungen, Eigenschaften, Eigenschaftsausprägungen und Sachgebiete zugeordnet werden
- Anlegen untergeordneter Stichworte möglich
- Zuordnung von Audio-Dateien (Soundkarte+Mikrofon erforderlich)
- Zuordnen von Text/Erläuterungen
- Zuordnen von Bildern
- Zuordnen und Verwalten von Links
- Ratingfunktion, zur qualitativen Bewertung von Links
- Anlegen selbst definierter Eigenschaften und Sachgebiete
- Automatisiertes und manuelles Aufbauen von Querverweisen
- verschiedene Druckmöglichkeiten, inklusive skaliertem Ausdruck von Bildern
- differenzierte Navigation
- gezielte Suche nach Stichworten
- spezielle Filterfunktionen
- Statistik
- Importfunktionen
- Export in viele andere Formate
- Ausgabe in HTML/XML
- Publizieren einzelner Einträge oder einer Liste von Einträgen als RSS-Feed (RSS 2.0) im Internet; in Verbindung mit der Möglichkeit zum Anhängen von Dateien ist so z.B. auch auf einfache Weise ein "Podcasting" (Verteilen von Audio-/Video-Dateien über das Internet) möglich

Weblogs:

- Erstellen von chronologisch absteigend geordneten Log-Einträgen
- Publizieren einzelner Einträge oder einer Liste von Einträgen als RSS-Feed (RSS 2.0) im Internet
- Ausgabe in verschiedene andere Formate (u.a. HTML, XML)
- Alle Funktionen, die für Projekte vom Typ "Enzyklopädie" möglich sind, sind auch für Weblog-Projekte nutzbar (Zuordnung von Dateien, Links, Bildern usw.)

Weitere Funktionen (für Wörterbücher, Enzyklopädien und Weblogs):

- Prüfung auf schon vorhandene Stichworte, schon bei der Eingabe
- Bearbeitungshilfen (z.B. Statusfeld 'In Bearbeitung')
- Verwendung von Abkürzungen für Eigenschaften/Sachgebiete
- Auffinden mehrfach vorhandener Einträge
- Zuordnung von beliebig vielen Dateianhängen (ohne Einschränkung auf bestimmte Dateiformate) zu einem Eintrag. So können einem Eintrag beliebige formatierte Informationen zugeordnet werden, z.B. Tabellen, Präsentationen, Abbildungen usw.
- Historie geänderter und neu hinzugefügter Einträge


word9fci

Neue Funktionen

Die aktuelle Wordbook-Version enthält u.a. die folgenden neuen Funktionen bzw. Erweiterungen:

ab Wordbook (Version 2023.01):
- Konfigurierbarer zentraler Ordner für Wordbook-Datenbanken
- Verbesserte Eingabe von Eigenschaften/Sachgebieten, inkl. neuer Upload-Funktion für Eigenschaften/Sachgebiete
- Korrektur bekannter Fehler
- verbesserte Programmstabilität

ab Wordbook (Version 2018.01):
- Diese Programmversion enthält eine Suchen und Ersetzen-Funktion. Mit dieser neuen Funktion ist ein Suchen und Ersetzen über eine gesamte Wordbook-Datenbank hinweg möglich.
- Die Funktion Stichwörter aus Text übernehmen ermöglicht es nun den Kontext der zu übernehmenden Stichworte bzw. ganze Sätze zu den Fundstellen entweder im Erläuterungsfeld oder als Entsprechungen zu speichern.
- Fehlerprotokollierung: Aufgetretene Fehler werden nun in einer Log-Datei protokolliert. Die Log-Datei befindet sich im Wordbook-Programm-Ordner.

ab Wordbook (Version 2017.03):
- Die HTML-Ausgabe wurde komplett überarbeitet und an den aktuellen Standard für Webseiten angepasst. Die Aufbereitung der HTML-Ausgabe von Wörterbüchern erfolgt jetzt zu 100% konform zum HTML5-Standard. Bei der HTML-Ausgabe wird jeweils eine Hauptseite (Indexseite) generiert. Außerdem werden einheitliche Kopf- und Fußzeilen ausgegeben. Über die Kopfzeile ist jeweils ein Rücksprung zur Indexseite möglich. Außerdem wurde die Ausgabe von Querverweisen neu gestaltet: Querverweise funktionieren jetzt innerhalb der HTML-Ausgabe als interaktive Hyperlinks. So ist es nun möglich ein erstelltes Wörterbuch im HTML-Format auszugeben, in dem dann dynamisch ausgehend von einem Stichwort andere verwandte Stichwörter (Synonyme, usw.) aufgerufen werden können. Diese Technik kann ebenso auf Wordbook-Datenbanken vom Typ „Lexikon/Enzyklopädie“ bzw. „Weblog“ angewendet werden!
- Die Ausgabe im XML- und RSS-Format wurde ebenfalls an die jeweils aktuellen Standards angepasst. Auch diese Formate werden standardkonform generiert.
In der Menüleiste wurden Buttons für den Aufruf der Ausgabe in folgenden Formaten hinzugefügt:
HTML
XML
STD (Steuerdatei für Seriendruck)
RSS
- Die Generierung von Querverweisen wurde ebenfalls komplett überarbeitet. Die Treffermenge wurde dadurch verbessert. Es können nun auch Rückverweise automatisch erzeugt werden. Ebenso konnte die Performance der Querverweis-Erstellung verbessert werden.

ab Wordbook (Version 2017.02):
- verbesserte Benutzerführung bei der Stichworteingabe
- Filteroptionen (gezielte Beeinflussung der Sortierung/Alfabetisierung bzgl. vorangestellten Sonderzeichen, Artikeln, usw. möglich)

ab Wordbook (Version 2017.01):
- Batch-Eingabe-Möglichkeit für Stichwörter und Entsprechungen

ab Wordbook (Version 2016.01):
- Neue Berichte zur Produktivität
- Programminterne Verbesserungen
- Überarbeitete Programm-Hilfe

ab Wordbook (Version 2015.02):
- Eine Programm-Komponente wurde ausgetauscht, damit sich Wordbook künftig unabhängiger von anderen Softwareprodukten installieren lässt.
- Es gab Änderungen bezüglich der einsetzbaren Lautschrift.

ab Wordbook (Version 2015.01):
- Beim Programm-Start wird die zuletzt geöffnete Datenbank automatisch geöffnet.
- Das Registrierungsverfahren wurde neu gestaltet. Die Demo-Version kann jetzt nach Eingabe eines Registierungs-Keys unmittelbar als Vollversion weiter verwendet werden.
- Die interne Datenverwaltung wurde in Teilen überarbeitet.

ab Wordbook (Version 2014.04):
- Die Funktion Stichwörter aus Text übernehmen ermöglicht es nun auch automatisch Eigenschaften und/oder Sachgebiete zuzuordnen.
- Die Formatierung durch Stylesheets (CSS) wurde überarbeitet und ermöglicht nun eine genauere Formatierung der Anzeige von Stichwörtern und eine verbesserte formatierte HTML-Ausgabe.
:
ab Wordbook (Version 2014.03):
- Die Funktion “Import aus anderen Wordbook-Datenbanken” wurde verbessert, so daß nun zwei (oder mehrere) Wordbook-Datenbanken zusammengeführt werden können.

ab Wordbook (Version 2014.02):
- Mit der neuen Funktion Stichwörter aus Text übernehmen können Stichworte automatisiert aus einem Voll-Text (TXT-Datei) eingelesen werden. Der Text wird dabei automatisiert in Wörter (und Sätze) als Textbestandteile zerlegt. Optional kann auch die Häufigkeit des Vorkommens von Wörtern in einem Text automatisiert ermittelt werden.

ab Wordbook (Version 2014.01):
- Das Vokabeltraining ermöglicht jetzt auch das Trainieren von Beispielen und deren Übersetzungen.
- Es wurde ein neuer Bericht (Falsch beantwortete Vokabeln) hinzugefügt.
- Außerdem wurde die Auswertungslogik des Vokabeltrainings verbessert.

Historie der Vorgänger-Versionen:

ab Wordbook 2012r (Version 23):
- verschiedene Verbesserungen beim Export und Import
- es können jetzt auch Bemerkungen mit importiert werden
- für einfache Textdateien (.TXT, .CSV) werden jetzt verschiedene Importformate unterstützt (u.a. Unicode, UTF-8)

ab Wordbook 2012r (Version 22):
- Das Bemerkungs-/Erläuterungsfeld ist jetzt unicode-fähig. Hieraus ergeben sich neue Möglichkeiten, da jetzt z.B. auch mehrsprachige Lexika angelegt werden können.
- neues Dienstprogramm zum Löschen von Einträgen eines bestimmten Zeitraums
- automatisches Hochzählen der Sortierpriorität bei untergeordneten Stichworten

ab Wordbook 2012r (Version 21):
- Erweiterungen für die Nutzung von Lautschrift
- Erweiterung der Suchfunktion für Datenbanken vom Typ Lexika/Enzyklopädien: Suche über URLs ist jetzt möglich

ab Wordbook 2012r (Version 20):
- Verbesserungen bei der Aktualisierung älterer Datenbanken-Versionen
- neuer Dialog zur Datensicherung
- neue Berichte für das Vokabeltraining

ab Wordbook 2012r (Version 19):
- In den Umgebungs-Einstellungen können Programme zum Öffnen von Dateianhängen gepflegt werden.
- Es gibt eine neue editierbare Ansicht um Stichworte ohne Entsprechungen aufzufinden und einzutragen.
- Bei den Filter-Einstellungen können jetzt auch mehrere Sachgebiete/Eigenschaften gleichzeitig eingestellt werden.
- die Schnellsuche/-Eingabe in der Hauptansicht wurde hinsichtlich der Performance verbessert. Außerdem kann jetzt auch mit Wildcards (*) gesucht werden.

ab Wordbook 2012r (Version 18):
- in der Hauptansicht wurde eine neue Registerkarte ‘Übersicht’ als Standardansicht eingefügt. Die Übersicht zeigt alle Informationen zu einem Stichwort in einem in Wordbook integrierten Web-Browser an.

ab Wordbook 2012r (Version 17):
- die Funktion Vokabeltraining wurde komplett überarbeitet.

ab Wordbook2012r (Version 15):
- es existiert eine neue Übersicht über verschiedene Dienstprogramme.
- In Bildern in der Vollbild-Ansicht kann jetzt direkt navigiert werden.
- Stichworte mit bestimmten zugeordneten Eigenschaften oder Sachgebieten können insgesamt durch eine Löschlauf gelöscht werden. So kann bsp.weise eine Eigenschaft ‘Löschvormerkung’ zu Stichworten zugeordnet werden, um diese Stichworte für ein späteres Löschen zu markieren.

ab Version 2012r:
- Umstellung des Programms auf Unicode für die Eingabe von Stichworten sowie deren Entsprechungen, Beispiele
und Beispielübersetzungen, d.h. die Eingabe von Zeichen anderer Sprachen wurde maßgeblich verbessert.
- Die bisherige Programm-Funktionalität wurde überarbeitet und in vielen Details verbessert.
- Bilder importieren (Mehrfachauswahl)
- Bilder können zudem auch direkt aus der Zwischenablage abgespeichert werden. Diese Möglichkeit eignet sich insbesondere auch zum Abspeichern von beliebigen Screenshots, um auf diese Weise Informationen in Wordbook abzulegen (Kommentare, Eigenschaften, Sachgebiete, Querverweise können zusätzlich hinzugefügt werden).

ab Version 2010r:
- Datenbank mit aktuellen Filter-Einstellungen speichern
- Datenbankkopie erstellen

ab Version 2008r:
- verbesserte Berichtsausgabe
- neue Dienst-Programme
- überarbeitete Filterfunktionen.

ab Version 2007:
- neuer Projekttyp Weblog ("Blog") zum Anlegen chronologisch absteigend geordneter Einträge
- Ausgabe von Einträgen als News-Feed im RSS-Format
- Kopieren in die Zwischenablage im RSS-Format
- Historie für neue und geänderte Einträge
- erweiterte Filterfunktionen


word9flf

Erste Schritte

So gehen Sie vor, um eine neue Wordbook-Datenbank anzulegen:

1. Rufen Sie den Menüpunkt Datei-Neu auf, um eine neue Datenbank anzulegen
2. Wählen Sie aus, ob Sie ein Wörterbuch anlegen wollen oder eine Enzyklopädie/ein Lexikon/eine Link-Sammlung, ... oder eine Datenbank vom Typ "Weblog".

Wörterbücher bieten die Möglichkeit zu Begriffen Entsprechungen, Beispiele, Beispielübersetzungen sowie die Aussprache von Begriffen zu speichern. Bilder könnnen ebenfalls gespeichert werden.

Enzyklopädien erlauben es hingegen, Begriffe und zugehörige Links, Bilder, Texte usw. zu speichern.

Weblogs sind geeignet für Projekte, bei denen es um die chronologische Reihenfolge der Einträge geht. Ansonsten entspricht dieser Datenbank-Typ dem Typ "Enzyklopädie".

3. Geben Sie dem neuen Projekt einen gültigen Dateinamen und klicken Sie abschließend auf OK.
4. Die neue Datenbank sowie ein gleichnamiger Ordner für Audio- und Bild-Dateien wird angelegt.

Für Wörterbücher:

5. Erstes Stichwort anlegen

6. Entsprechungen und andere Informationen zum Stichwort eingeben

Für Enzyklopädien:

5. Erstes Stichwort anlegen

6. Informationen zum Stichwort eingeben

Für Weblogs("Blogs"):

5. Erstes Stichwort anlegen

6. Informationen zum Stichwort eingeben


word9flg

Hauptansicht

Nach dem Neuanlegen oder Öffnen einer Datenbank (Wörterbuch oder Enzyklopädie) gelangen Sie zur Hauptansicht. Am oberen Bildschirmrand befindet sich die Funktions- bzw. Menüleiste. Am unteren Bildschirmrand werden Statusfunktionen und Bedienungshinweise angezeigt.

Darunter befindet sich ein Fenster, in dem links die vorhandenen Stichworte angezeigt werden. Beachten Sie die beiden Navigations-Buttons zum Blättern durch die vorhandenen Stichworte.

Schnellsuche/-Eingabe
Im Eingabefeld zur Schnellsuche kann direkt nach vorhandenen Stichwörtern gesucht werden. Abhängig von der Eingabe werden nur die dazu passenden Stichwörter aufgelistet. Es ist auch möglich mit Wildcards zu suchen (z.B. *om findet alle Stichwörter die die Zeichenfolge ‘om’ enthalten). Wenn ein Stichwort nicht gefunden wird, so kann über die Enter-Taste direkt der Dialog zum Neuanlegen des Stichworts gestartet werden. Bereits vorhandene Stichwörter können bearbeitet werden.

Registerkarte Übersicht
Wenn Sie ein Stichwort auswählen, werden die zugehörigen Entsprechungen, Eigenschaften, ... sowie falls vorhanden auch Bilder in einer Webbrowser-basierten Ansicht angezeigt.
Abhängig davon, ob es sich um ein Wörterbuch, eine Enzyklopädie oder eine Datenbank vom Typ "Weblog" handelt werden unterschiedliche Informationen angezeigt.

Die Webbrowser-basierte Hauptansicht hat den Vorteil, dass sie alle Informationen zu einem Stichwort auf einen Blick beinhaltet. Über die rechte Maustaste ist zudem ein Menü mit typischen Webbrowser-Funktionen aufrufbar. Das aktuell ausgewählte Stichwort kann auf diesem Weg auch ausgedruckt werden. Sind Links zu einem Stichwort vorhanden, so können diese über diese Ansicht direkt aufgerufen werden. Die Navigation zurück erfolgt ggf. ebenfalls über die rechte Maustaste.

Die Formatierung der ‘Übersicht’ erfolgt über die mitgelieferten CSS-Vorlagen (Cascading Stylesheets), die sich im Programmordner ‘Stylesheets’ befinden. Die Stylesheets können von Ihnen angepasst werden, so dass Sie die Formatierung (Schriftgrößen, Farben, usw.) individuell anpassen können. Sie können angepasste Stylesheets auch unter einem eigenen Dateinamen speichern. Über Extras -> Einstellungen -> Web-Berichtsausgabe kann das aktuell verwendete Stylesheet eingestellt werden.

Registerkarte Bild
Bilder können in der Größe verändert und auch im Voll-Bild-Modus angezeigt werden. Über die Bild-Tasten (Page Up/Page Down) kann durch die vorhandenen Bilder navigiert werden. Mit den Pfeiltasten <- und -> können Bilder zur Ansicht um jeweils 90 Grad nach links oder rechts gedreht werden.

Die Funktionen zum Anlegen, Bearbeiten, Drucken und Löschen von Einträgen lassen sich auch mit der rechten Maustaste aufrufen.

Am oberen Rand des Fensters sind verschiedene Filter-Funktionen angeordnet.

Es können auch mehrere Fenster nebeneinander angezeigt werden.


word9flh

Stichworte, Entsprechungen, usw. eingeben

Im Eingabeformular (für Datenbanken vom Typ "Wörterbuch") können Sie verschiedene Informationen zu einem Stichwort eingeben. Das Eingabeformular besteht aus mehreren Registerkarten. Es ist wichtig, den Aufbau des Eingabeformulars zu verstehen:

Registerkarte Stichwort/Entsprechung

Hier können Sie einen Stichwort sowie beliebig viele Entsprechungen dazu eingeben.
Falls Sie den Buchstaben- und Zeichensatz einer bestimmten Sprache auf Ihrer Tastatur benötigen, so müssen Sie diesen durch das Betriebssystem Ihres Computers einstellen (Ordner Systemsteuerung -> Tastatur -> Sprache).

Neue Entsprechungen werden links im Eingabeformular in das Eingabefeld eingegeben und mit Klick auf den daneben befindlichen Pfeil hinzugefügt.
Abhängig von der Eingabe werden unterhalb die bereits vorhandenen Entsprechungen angezeigt. Somit besteht die Möglichkeit, bereits vorhandene Entsprechungen zu einem neuen Stichwort per Doppelklick direkt bei der Stichwort-Eingabe zu übernehmen.

Ausserdem können Sie die Aussprache des Stichworts eingeben. Beachten Sie, dass im Aussprachefeld die Tastatur mit einer speziellen Lautschrift belegt ist. Die zu verwendende Lautschrift kann unter den Programm-Einstellungen eingestellt werden.
Die Lautschrift läßt sich auch per Mausdoppelklick über die abgebildete Lautschrifttabelle eingeben.
Stichworte können hier auch vertont werden, wenn Ihr Computer mit Soundkarte und Mikrofon ausgestattet ist. Gehen Sie dazu folgendermaßen vor:

- Klicken Sie auf den grünen Audio-Aufnahme-Button.
- Sprechen Sie die Vertonung in das angeschlossene Mikrofon.
- Klicken Sie auf den gelben Speichern-Button.
- Überprüfen Sie die Aufnahme mit dem Wiedergabe-Button.

Sie können Stichworte zudem mit einem Bearbeitungstatus versehen. Wenn dieses Feld angekreuzt ist, so können Sie die Stichworte später leicher auffinden, indem Sie einen entsprechenden Filter setzen.

Registerkarte Stichwort -> Eigenschaften/Sachgebiete

Zu jedem Stichwort können Sie beliebig viele Eigenschaften und Sachgebiete eingeben. Dazu finden Sie vordefinierte Standard-Eigenschaften und -Sachgebiete. Eigenschaften sind beispielsweise Subjekt, männlich, usw. Sachgebiete sind z.B. Biologie oder Geschichte.
Sie können (siehe unten) aber auch selbst neue Eigenschaften und Sachgebiete definieren.
Das Zuordnen der Eigenschaften und Sachgebiete zu einem Stichwort ist denkbar einfach. Wählen Sie eine Eigenschaft aus und klicken Sie auf den abgebildeten Rechtspfeil (oder klicken Sie doppelt).

Zu jeder Eigenschaft kann ausserdem ein Eigenschaftswert eingegeben werden.
Beachten Sie, daß regelmäßig benötigte Eigenschaften und Sachgebiete auch automatisch vergeben werden können!

Registerkarte Entsprechung -> Eigenschaften/Sachgebiete

Die Zuordnung von Eigenschaften und Sachgebieten zu Entsprechungen funktioniert wie die Zuordnung zu Stichworten (siehe oben).
Zu jeder Eigenschaft kann ebenfalls ein Eigenschaftswert eingegeben werden.
Der einzige Unterschied besteht darin, dass Sie erst eine Entsprechung auswählen müssen, bevor Sie Eigenschaften und Sachgebiete vergeben können (da es oft mehrere Entsprechungen zu einem Stichwort gibt)!

Registerkarte Entsprechung -> Beispiele

Auch um Beispiele und Beispielübersetzungen einzugeben, müssen Sie erst per Mausklick eine Entsprechung auswählen. daraufhin erscheint eine Tabelle, in die Sie beliebig viele Beispiele und Entsprechungen eingeben können. Neue Beispiele und Beispielübersetzungen müssen in die Zeile mit Sternchen (*) der im Eingabeformular sichtbaren Tabelle eingegeben werden.

Registerkarte Beschreibung

Hier können Sie einen beschreibenden Text zum Stichwort eingeben. Ein erläuternder Text kann auch aus einer vorhandenen Textdatei geladen werden.
Hinweis: Seit Wordbook 2012r (Version 22) kann für Beschreibungen/Erläuterungen eine eigene Schriftart eingestellt werden. Da dieses Feld nun ebenfalls unicode-fähig ist, können nun auch fremdsprachige Zeichen (auch längere Texte) in dieses Feld eingegeben werden.

Registerkarte Eigenschaften/Sachgebiete

Hier können Sie neue Eigenschaften und Sachgebiete anlegen. Dabei erfolgt keine Zuordnung zu einem Stichwort oder einer Entsprechung!
Neue Eigenschaften und Sachgebiete müssen in die Zeile mit Sternchen (*) der im Eingabeformular sichtbaren Tabellen eingegeben werden.

Registerkarte Bild

Zu jedem Stichwort kann ein Bild eingescannt werden oder aus eine Datei geladen werden.
Bilder können zudem auch direkt aus der Zwischenablage abgespeichert werden. Diese Möglichkeit eignet sich insbesondere auch zum Abspeichern von beliebigen Screenshots, um auf diese Weise Informationen in Wordbook abzulegen (Kommentare, Eigenschaften, Sachgebiete, Querverweise können zusätzlich hinzugefügt werden).
Bevorzugtes Bildformat ist JPG da dies auch bei der Berichtsausgabe sowie der Ausgabe in HTML-Seiten angezeigt werden kann..
Achtung: Die von Wordbook verwendete Berichtskomponente unterstützt derzeit die folgenden Bildformate: .bmp, .tiff, .jpg, .png, oder .wmf. Andere Bildtypen können möglicherweise zwar innerhalb von Wordbook angezeigt, aber nicht in Berichtsform ausgegeben werden.

Registerkarte Querverweise

Zu jedem Stichwort können beliebig viele Querverweise zu bereits vorhandenen Stichworte erstellt werden. Querverweise können jederzeit manuell zu Stichworten hinzugefügt werden. Es existiert eine eigene Funktion, mit der Querverweise automatisch aufgebaut werden können. -> Querverweise aufbauen

Registerkarte Regeln

Auf jedes Stichwort können beliebig viele Regeln angewendet werden. Beachten Sie, dass dies eine sehr mächtige und vielseitig einsetzbare Funktion ist. Mit den von Ihnen definierten Regeln können beispielsweise die verschiedenen (regelmässigen) Formen eines Verbs abgebildet und dann den jeweiligen Stichworten (Stammformen) zugeordnet werden. Es sind jedoch auch eine Vielzahl anderer Anwendungsmöglichkeiten denkbar.

Registerkarte Dateianhang

Zu jedem Stichwort können beliebig viele Dateianhänge zugeordnet werden. Dies können beliebige Dateien (z.B. Excel, PDF, Word) sein. Auf diese Weise können Einträgen beliebig formatierte Informationen (Tabellen, Abbildungen usw.) zugeordnet werden.
Zu jedem Dateianhang kann eine Bezeichung sowie eine kurze Beschreibung eingegeben werden. Wahlweise kann ein Verweis auf die entsprechende Datei an ihrem aktuellen Speicherort erstellt werden oder die Datei wird separat (als Kopie) in einem speziellen Ordner gespeichert. Die Dateianhänge können direkt aus Wordbook heraus per Mausklick geöffnet werden.

Sie beenden Ihre Eingaben zu dem Stichwort durch 'Eintragen und Schließen' oder Sie geben weitere Stichworte ein durch 'Eintragen und Neu...'.

Tipp:
Um schneller arbeiten zu können ist es hilfreich, zuerst nur Stichworte und Entsprechungen einzugeben. Sie bewegen sich somit nur auf der 1. Registerkarte. Dabei können sämtliche Eingaben auch ohne Hilfe der Maus, unterstützt durch Shortcuts, vorgenommen werden.
Eigenschaften, Sachgebiete, Beispiele, usw. können Sie dann später zu den Stichworten hinzufügen.


word9fli

Informationen zum Stichwort eingeben

Im Eingabeformular (für Datenbanken vom Typ "Enzyklopädie" oder "Weblog") können Sie alle möglichen Informationen zu einem Stichwort eingeben. Das Eingabeformular besteht aus mehreren Registerkarten. Es ist wichtig für Sie, den Aufbau des Eingabeformulars zu verstehen.

Registerkarte Stichwort

Hier können Sie ein Stichwort eingeben.
Stichworte können hier auch vertont werden, wenn Ihr Computer mit Soundkarte und Mikrofon ausgestattet ist. Gehen Sie dazu folgendermaßen vor:
- Klicken Sie auf den grünen Audio-Aufnahme-Button.

- Sprechen Sie die Vertonung in das angeschlossene Mikrofon.
- Klicken Sie auf den gelben Speichern-Button.
- Überprüfen Sie die Aufnahme mit dem Wiedergabe-Button.

Sie können Stichworte zudem mit einem Bearbeitungstatus versehen. Wenn dieses Feld angekreuzt ist, so können Sie die Stichworte später leicher auffinden, indem Sie einen entsprechenden Filter setzen.

Registerkarte Stichwort -> Eigenschaften/Sachgebiete

Zu jedem Stichwort können Sie beliebig viele Eigenschaften und Sachgebiete eingeben. Dazu finden Sie vordefinierte Standard-Eigenschaften und -Sachgebiete. Eigenschaften sind beispielsweise Subjekt, männlich, usw. Sachgebiete sind z.B. Biologie oder Geschichte.

Sie können (siehe unten) aber auch selbst neue Eigenschaften und Sachgebiete definieren.
Das Zuordnen der Eigenschaften und Sachgebiete zu einem Begriff ist denkbar einfach. Wählen Sie eine Eigenschaft aus und klicken Sie auf den abgebildeten Rechtspfeil (oder klicken Sie doppelt).

Tipp:
Die Listen mit den enthaltenen Eigenschaften/Sachgebieten reagieren auf Benutzereingaben. Um Eigenschaften/Sachgebiete schnell aufzufinden gehen Sie am besten wie folgt vor:
-> Anklicken der Liste
-> Eingeben des Anfangsbuchstabens (oder mehrerer Anfangsbuchstaben) der gesuchten Eigenschaft/des gesuchten Stichworts. Hierdurch wird automatisch an die jeweilige Listenposition navigiert.
-> Übernahme der Eigenschaft/des Sachgebietes mit Doppelklick

Zu jeder Eigenschaft kann ausserdem ein Eigenschaftswert eingegeben werden.
Beachten Sie, daß regelmäßig benötigte Eigenschaften und Sachgebiete auch automatisch vergeben werden können!

Registerkarte Beschreibung

Hier können Sie einen beschreibenden Text zum Stichwort eingeben. Ein erläuternder Text kann auch aus einer vorhandenen Textdatei geladen werden.

Registerkarte Eigenschaften/Sachgebiete

Hier können Sie neue Eigenschaften und Sachgebiete anlegen. Dabei erfolgt keine Zuordnung zu einem Stichwort oder einer Entsprechung!
Neue Eigenschaften und Sachgebiete müssen in die Zeile mit Sternchen (*) der im Eingabeformular sichtbaren Tabellen eingegeben werden.

Registerkarte Bild

Zu jedem Stichwort kann ein Bild eingescannt werden oder aus eine Datei geladen werden.
Bilder können zudem auch direkt aus der Zwischenablage abgespeichert werden. Diese Möglichkeit eignet sich insbesondere auch zum Abspeichern von beliebigen Screenshots, um auf diese Weise Informationen in Wordbook abzulegen (Kommentare, Eigenschaften, Sachgebiete, Querverweise können zusätzlich hinzugefügt werden).
Bevorzugtes Bildformat ist JPG da dies auch bei der Berichtsausgabe sowie der Ausgabe in HTML-Seiten angezeigt werden kann..
Achtung: Die von Wordbook verwendete Berichtskomponente unterstützt derzeit die folgenden Bildformate: .bmp, .tiff, .jpg, .png, oder .wmf. Andere Bildtypen können möglicherweise zwar innerhalb von Wordbook angezeigt, aber nicht in Berichtsform ausgegeben werden..

Registerkarte Links

Zu jedem Stichwort können beliebig viele Links eingegeben werden. Dazu gehört eine Linkbeschreibung, die URL sowie die Möglichkeit eine Erläuterung zur URL einzugeben.
Zu jedem Link kann zusätzlich eine Bewertung (Rating) angegeben werden. Das Rating wird bei der HTML-Ausgabe in Form von Sternchen (***) ausgegeben, um die Qualität von Links zu kennzeichnen.

Die Links können direkt aus Wordbook aufgerufen werden, d.h. bei Mausklick auf die URL wird (falls vorhanden) der Webbrowser gestartet.

Registerkarte Querverweise

Zu jedem Stichwort können beliebig viele Querverweise zu bereits vorhandenen Stichworte erstellt werden. Querverweise können jederzeit manuell zu Stichworten hinzugefügt werden. Es existiert eine eigene Funktion, mit der Querverweise automatisch aufgebaut werden können. -> Querverweise aufbauen

Registerkarte Dateianhang

Zu jedem Stichwort können beliebig viele Dateianhänge zugeordnet werden. Dies können beliebige Dateien (z.B. Excel, PDF, Word) sein. Auf diese Weise können Einträgen beliebig formatierte Informationen (Tabellen, Abbildungen usw.) zugeordnet werden.
Zu jedem Dateianhang kann eine Bezeichung sowie eine kurze Beschreibung eingegeben werden. Wahlweise kann ein Verweis auf die entsprechende Datei an ihrem aktuellen Speicherort erstellt werden oder die Datei wird separat (als Kopie) in einem speziellen Ordner gespeichert. Die Dateianhänge können direkt aus Wordbook heraus per Mausklick geöffnet werden.

Sie beenden Ihre Eingaben zu dem Stichwort durch 'Eintragen und Schließen' oder Sie geben weitere Stichworte ein durch 'Eintragen und Neu...'.

Tipp:
Um schneller arbeiten zu können ist es hilfreich, zuerst nur Stichworte und Beschreibungen/Erläuterungen einzugeben. Sie bewegen sich somit nur auf der 1. Registerkarte. Dabei können sämtliche Eingaben auch ohne Hilfe der Maus, unterstützt durch Shortcuts, vorgenommen werden.
Eigenschaften, Sachgebiete, usw. können Sie dann später zu den Stichworten hinzufügen.


word9flj

Untergeordnete Stichworte eingeben

Eine Besonderheit von Wordbook besteht darin, daß - für alle Datenbanktypen - untergeordnete Stichworte angelegt werden können. Dies bietet sich z.B. für Wortfamilien bzw. generell für miteinander zusammenhängende Themen - an.
Um einen untergeordneten Eintrag anzulegen, müssen Sie zuerst ein Stichwort auswählen, zu dem der untergeordnete Eintrag angelegt werden soll. Anschliessend kann per rechtem Mausklick (oder über die Menüsymbole) ein neues untergeordnetes Stichwort angelegt werden.
Das Eintragen erfolgt ansonsten wie bei den Stichworten der 'ersten Ebene'.

Einzige Besonderheit ist, daß Sie für untergeordnete Stichworte optional eine Sortierpriorität angeben können. Dies benötigen Sie jedoch nur, falls Sie einem Stichwort mehrere Stichworte unterordnen möchten. Verwenden Sie zur Festlegung der Sortierreihenfolge der untergeordneten Stichworte Zahlen (0,1,2,...).
Untergeordnete Einträge können auch wieder zur ersten Ebene zurückgestuft werden.


word9flk

Programm-Beschreibung

Als weitere Datenbank öffnen

Neue Eigenschaften/Sachgebiete anlegen

Eigenschaften/Sachgebiete automatisch zuordnen

Querverweise anlegen

Eintrag suchen

Gehe zu...

Nach Stichwörtern suchen

Regeln (nur für Wörterbücher)

Statistik

Übersicht Dienstprogramme

Suchindex neu aufbauen

Sortierung neu aufbauen

Filter setzen

Einstellungen zur aktuellen Wordbook-Datenbank

Umgebung

Identische Einträge finden

Vokabeltraining (nur für Wörterbücher)

Auswahl

Ansichten

Bericht drucken

Standardberichte

Bericht in Serienbrief-Steuerdatei ausgeben

Bericht in HTML-Datei ausgeben

Bericht in XML-Datei ausgeben

Bericht in RSS-Datei ausgeben

Ausgewählten Eintrag drucken

Eintrag in Zwischenablage kopieren

Eintrag im RSS-Format in die Zwischenablage kopieren

Eintrag im RSS-Format in die Zwischenablage kopieren (mit Dateiverweisen)

Bild in Zwischenablage kopieren

Eintrag umhängen

Eigenschaften/Sachgebiete löschen

Import von Eigenschaften/Sachgebieten

Import aus anderen Wordbook-Datenbanken

Import aus externen Datenbanken

Bilder importieren (Mehrfachauswahl)

Übersetzungsrichtung umkehren (nur für Wörterbücher)

Datenbank exportieren

Datenbank kompaktieren

Datenbank reparieren

Datenbank sichern

Datenbankkopie erstellen

Historie

Produktivität

Batch-Eingabe


word9fll

Beispiele

Im folgenden Abschnitt finden Sie einige Beispiele zu verschiedenen Themen:

Formatvorlage zur Erstellung von Wörterbüchern/Enzyklopädien (Word)

Eigenschaften und Eigenschaftswerte

Querverweise

Regeln


word9f5c

Support und Vertrieb

Die Software Wordbook wird entwickelt und vertrieben von:

Wordbook Software
Brüder-Grimm-Str. 37
DE-60385 Frankfurt am Main

Telefon/Fax ++49-(0)69-48982264

E-Mail: info(at)wordbook.de
Internet: www.wordbook.de


word9f5d

Erstes Stichwort anlegen (Wörterbücher)

1. Anschließend werden Sie aufgefordert einen ersten Begriff in das neue Wörterbuch einzutragen. Zu diesem Zeitpunkt sollten Sie spätestens wissen, was Ihr Wörterbuch eigentlich enthalten soll. Insbesondere sollten Sie wissen, in welche Richtung Sie übersetzen möchten. Möchten Sie beispielsweise ein Spanisch -> Deutsch-Wörterbuch anlegen, dann muß der erste Begriff ein spanischer Ausdruck sein (die deutschen Entsprechungen dazu geben Sie später ein).
2. Geben Sie ausserdem die Übersetzungsrichtung an, indem Sie die entsprechende Sprache auswählen. Nicht aufgeführte Sprachen können Sie selbst hinzufügen.
Hinweis: Seit Wordbook 2012r (Version 22) kann für Beschreibungen/Erläuterungen eine eigene Schriftart eingestellt werden. Da dieses Feld nun ebenfalls unicode-fähig ist, können nun auch fremdsprachige Zeichen (auch längere Texte) in dieses Feld eingegeben werden.
3. Bestimmen Sie je eine Schriftart für beide Übersetzungsrichtungen. Falls Sie keine Schriftart angeben wird die Standardschrift verwendet.
4. Optional können Sie eine Kurzbeschreibung für das Wörterbuch eingeben, z.B. Spanisch-Deutsch Grundwortschatz.
5. Klicken Sie zum Abschluß auf OK.

Als nächstes folgt:

6. Entsprechungen und andere Informationen zum Begriff eingeben


word9f5e

Filter setzen

Sie können zur Auswahl bestimmter Einträge Filter setzen. Beispielsweise können Sie sich so nur diejenigen Einträge anzeigen lassen, die bestimmte Eigenschaften besitzen.

Arbeitsweise der Filter:
Wenn mehrere Eigenschaften ausgewählt werden, so werden diese logisch mit ODER verknüpft (Vereinigungsmenge).
Werden Eigenschaften und gleichzeitig Sachgebiete ausgewählt, so werden diese logisch mit UND verknüpft (Schnittmenge).

Als Filter-Gültigkeitsbereich können Sie Stichwort oder Entsprechung einstellen. Weiterhin können Sie Einträge herausfiltern, die:
- den Status 'In Bearbeitung' besitzen,
- denen eine Erläuterung zugeordnet ist,
- denen eine Audio-Sequenz zugeordnet ist,
- denen ein Bild zugeordnet ist,
- denen ein Attachment (= angehängte Datei) zugeordnet ist,
- denen eine URL zugeordnet ist,
- denen ein Querverweis zugeordnet ist.

Sie können die Filter auch anwenden, um herauszufinden, ob einem Eintrag KEIN Bild, Attachment, Querverweis usw. zugeordnet ist. Dies ist u.a. nützlich, um beim Aufbau von Wordbook-Datenbanken noch fehlende Informationen zu Einträgen zu ergänzen.

Ausserdem gibt es noch die Funktion 'Liste nächste', mit der Sie angeben wieviele Einträge im Hauptfenster aufgelistet werden sollen. Bei umfangreichen Wordbook-Datenbanken ist es ratsam, hier einen höheren Wert einzustellen, um sich so schneller durch die Datenbestände bewegen zu können.

Das Setzen von Filtern können Sie auch beim Drucken, beim Standard-Reporting, beim Erstellen von Steuerdateien und HTML- bzw. XML- bzw. RSS-Seiten, beim Vokabeltraining sowie bei der Statistik einsetzen. Allerdings stehen kontextabhängig nicht immer alle Filter-Möglichkeiten zur Verfügung.

Bei bestimmten Aktionen (z.B. beim Neuanlegen von Stichwörtern) werden die Filter-Einstellungen programmgesteuert zurückgesetzt.


word9f5f

Bericht in HTML-Datei ausgeben

Diese Funktion ermöglicht es Ihnen ein erstelltes Wörterbuch, eine Enzyklopädie oder ein Weblog zur Veröffentlichung im World Wide Web im HTML-Format auszugeben. Dabei können Sie entweder den vollständigen Datenbankinhalt in HTML ausgeben oder nur bestimmte Abschnitte. Sie können Stichworte (Aussprache, Bemerkung, Eigenschaften, Sachgebiete,...) auswählen und Filter-Funktionen einsetzen. Sie können zudem die Anzahl der Stichworte je HTML-Seite einstellen.

-Die HTML-Ausgabe wurde komplett überarbeitet und an den aktuellen Standard angepasst. Die Aufbereitung der HTML-Ausgabe von Wörterbüchern erfolgt jetzt zu 100% konform zum HTML5-Standard. Bei der HTML-Ausgabe wird jeweils eine Hauptseite (Indexseite) generiert. Außerdem werden einheitliche Kopf- und Fußzeilen ausgegeben. Über die Kopfzeile ist jeweils ein Rücksprung zur Indexseite möglich. Außerdem wurde die Ausgabe von Querverweisen neu gestaltet: Querverweise funktionieren jetzt innerhalb der HTML-Ausgabe als interaktive Hyperlinks. So ist es nun möglich ein erstelltes Wörterbuch im HTML-Format auszugeben, in dem dann dynamisch ausgehend von einem Stichwort andere verwandte Stichwörter (Synonyme, usw.) aufgerufen werden können. Diese Technik kann ebenso auf Wordbook-Datenbanken vom Typ „Lexikon/Enzyklopädie“ bzw. „Weblog“ angewendet werden!

Mit der aktuellen Wordbook-Version können auch Verweise auf die mit Wordbook verwalteten Attachments mit veröffentlicht werden. Hierbei muss sichergestellt sein, dass der Ordner, der die Attachments enthält mit auf den Web-Server kopiert wird, damit die Attachments beim Aufruf der HTML-Seite auch angezeigt werden können.

Tipp:
Beachten Sie für das Publizieren im Internet auch die möglichen Einstellungen.
Wenn Sie den betreffenden Ordner, der zusammen mit der Datenbank angelegt wird, auf den Web Server kopieren, so werden die benötigten Objekte (Bilder, Attachments usw.) über den relativen Pfad gefunden und beim Aufruf der HTML-Seite entsprechend angezeigt.

Die erstellten HTML-Seiten können Sie nach Ihren Vorstellungen mit einem HTML-Editor anpassen und auf einem Web Server veröffentlichen.

Tipp:
Für professionelle Online-Wörterbücher im WWW können Sie die Exportfunktion oder auch die Ausgabe in XML von Wordbook nutzen. Die Exportfunktion erstellt eine MS Access-Datenbank, auf die Sie z.B. via ODBC auch über das Web zugreifen können. Die Verbindung von WWW-Seiten mit einer Datenbank ermöglichen diverse Werkzeuge. Nähere Hinweise hierzu gibt die entsprechende Literatur.


word9f5h

Bericht in XML-Datei ausgeben

Diese Funktion ermöglicht es Ihnen den Datenbankinhalt (oder den Inhalt mehrerer gleichzeitig geöffneter Datenbanken) im XML-Format (Extensible Markup Language) auszugeben. Dabei können Sie entweder den gesamten Datenbankinhalt nach XML exportieren oder nur bestimmte Abschnitte. Sie können Stichworte (Aussprache, Bemerkung, Eigenschaften, Sachgebiete,...) auswählen und Filter-Funktionen einsetzen.

Die erstellte XML-Datei ist vielseitig verwendbar. Sie können mit Hilfe von HTML und/oder Skriptsprachen darauf zugreifen und die XML-Daten somit beliebig aufbereiten und abfragen. Hinweise zu XML gibt die einschlägige Literatur.

Wenn das Häkchen 'Stylesheet verwenden' gesetzt ist, verwendet Wordbook die Stylesheet-Datei, die unter 'Einstellungen' angegeben ist zur formatierten Ausgabe. Sie können die mitgelieferten Stylesheets auch selbst anpassen, um auf einfache Weise Einfluss auf die Formatierung zu nehmen.


word9f5i

Querverweise

Ein Querverweis stellt einen Verweis von einem Stichwort in der Datenbank zu einem anderen Stichwort in der Datenbank dar.
Mit Wordbook können Verweise automatisch und manuell aufgebaut werden.

Manuell:
Hierzu verwenden Sie die Eingabemaske für Stichworte und dort die Registerkarte 'Querverweise'.
Dort sehen Sie eine Liste aller vorhandenen Stichworte, die Sie nun als Querverweis dem aktuell ausgewählten Stichwort zuordnen können.
Es können auch Rückverweise erstellt werden (z.B. bei Synonymen).
Sie können Querverweise auch wieder entfernen.

Automatisch:
Über den Menüauswahlpunkt 'Extras -> Dienstprogramme -> Querverweise aufbauen/aktualisieren' gelangen Sie zu einem Dialogfenster, von dem aus Sie den automatischen Aufbau von Querverweisen starten können. Hierbei haben Sie die Möglichkeit zu bestimmen, welche Text-Stichworte die Grundlage für den Aufbau von Querverweisen darstellen sollen. Je nachdem, was Sie ankreuzen, werden alle Stichworte, Erläuterungen, usw. nach bereits in der Datenbank vorhandenen Stichworten durchsucht. Werden vorhandene Stichworte gefunden, so wird automatisch ein Querverweis hergestellt.

Für den Aufbau von Querverweisen kann optional festgelegt werden, ob ganze Begriffe als Vergleichsmuster dienen sollen, oder nur eine bestimmte Anzahl von Zeichen. Die Gross-/Kleinschreibung kann ebenfalls berücksichtigt werden. Die Einstellung 'Nur mit Großbuchstaben beginnende Stichworte' ermöglicht es, Querverweise nur für Substantive aufzubauen.
Sie können ausserdem eine feste Zeichenfolge als Muster vorgeben, um gezielt Querverweise aufzubauen.

Auch beim automatischen Querverweisaufbau sind Rückverweise möglich. Zu beachten ist, dass dies dann für alle Querverweise durchgeführt wird, was nicht in jedem Fall gewünscht ist. Außerdem erhöht sich durch den Rückverweisaufbau auch die Laufzeit dieser Funktion insgesamt.

Um die Einstellungen zunächst zu testen, können Sie einen Testlauf durchführen, bei dem nur die ersten 100 Stichworte verschlagwortet werden. Kreuzen Sie hierzu die entsprechende Checkbox an. Prüfen Sie nach dem Testlauf das Ergebnis. Erst wenn Sie das gewünschte Resultat erzielt haben, sollten Sie damit beginnen, die Querverweise für alle Stichworte der Datenbank aufbauen. Diese Vorgehensweise ist dringend zu empfehlen, da der Aufbau von Querverweisen bei umfangreichen Datenbanken sehr zeitintensiv ist.

Das Aufbauen von Querverweisen stellt eine Abschlussarbeit im Verlauf des Aufbaus von Wordbook-Datenbanken dar. Sie können allerdings auch schon während des Aufbaus von Datenbanken mit dem Aufbau von Querverweisen beginnen und sukzessiv die Querverweise aktualisieren (Querverweise in diesem Fall NICHT löschen!). Wordbook erkennt automatisch neu hinzugekommene Stichworte und berücksichtigt diese, wenn Querverweise aufgebaut bzw. aktualisiert werden sollen.

Über 'Querverweise löschen' werden alle vorhandenen Querverweise gelöscht.

Seit der Programm-Version 2017.03 werden Querverweise bei der HTML-Ausgabe interaktiv dargestellt.

Tipp:
Beachten Sie weiterhin, dass durch einen Doppelklick auf die in der Wordbook-Hauptansicht sichtbaren Begriffe (z.B. im Fenster Beschreibung/Erläuterung) ein Suchdialog gestartet wird. Es kann somit von jedem vorhandenen Begriff ausgehend eine Suche initiiert werden, auch wenn die Funktion zum Aufbau von Querverweisen nicht explizit genutzt wird.


word9f5j

Regeln (nur für Wörterbücher)

Regeln dienen vor allem dazu, immer wiederkehrende Formen und Muster im Bereich der Sprache abzubilden und diese anschliessend einer bestimmten Grundform (Stammform) zuzuordnen. Ein Beispiel stellen regelmässig wiederkehrende Konjugationsformen dar. Wenn z.B. die spanischen Verben, die mit -er enden, im Präsens Indikativ auf eine bestimmte, regelmässig wiederkehrende Weise konjugiert werden, so kann dafür eine Regel angelegt werden. Um die verschiedenen benötigten Verbformen abzubilden, können sogenannte Regelvarianten angelegt werden. Diese müssen - bezogen auf das obige Beispiel - die folgenden Sachverhalte abbilden:

Nachstellen von

-o (1. Person Singular)
-es (2. Person Singular)
-e (3. Person Singular)
-emos (1. Person Plural)
-éis (2. Person Plural)
-en (3. Person Plural)

Mit Wordbook kann hierfür einmalig eine Regel (mit den zugehörigen Regelvarianten) erstellt werden. Anschliessend kann die Regel jedem Begriff eines Wörterbuchs zugeordnet werden, bei dem diese Regel sinnvoll angewendet werden kann. Bei der Anwendung der Regel auf einen Begriff werden sämtliche Regelvarianten ausgeführt, d.h. zu dem Begriff werden die entsprechenden Formen des Singulars und Plurals erstellt. Dies kann wahlweise so geschehen, dass die Formen als neue Unter-Stichworte angelegt werden oder die verschiedenen Formen werden im Beschreibungsfeld zu einem Stichwort abgespeichert.

Für Regelvarianten kann im Detail folgendes spezifiziert werden:

1. Zeichenfolge, die dem Stichwort vorangestellt werden soll

Dies kann z.B. das vorangestellte Personalpronomen zu einem Verb sein.

2. Ersetzen einer Zeichenfolge (innerhalb der ersten n Zeichen) durch eine andere Zeichenfolge

Hier können einzelne Zeichen durch andere Zeichen ersetzt werden.
Die Anzahl der Zeichen muss dabei nicht übereinstimmen. Z.B. kann e durch ie
ersetzt werden.

3. Ersetzen erste/mittlere/letzte Zeichen durch eine Zeichenfolge

Hier wird angegeben, wie die Stammform verändert werden soll. Wahlweise können Zeichen am Anfang, in der Mitte oder am Ende des Begriffs ersetzt werden.

4. Zeichenfolge, die dem Stichwort nachgestellt werden soll

Hier können z.B. Begriffsendungen abgebildet werden, die an eine bestimmte Stammform angehängt werden.

5. Sortierpriorität

Hier können Sie durch die eigene Vergabe einer entsprechenden Zahlenfolge die Reihenfolge beeinflussen, in der die Regelvarianten als UnterStichworte dargestellt werden sollen. Standardmässig wird automatisch durchnummeriert, d.h. es wird die Reihenfolge verwendet, in der Sie die Varianten eingeben.

Regelvarianten können darüber hinaus auch Eigenschaften oder Sachgebiete zugeordnet werden. Dies erlaubt es, die Regelvariante näher zu spezifizieren. Bezogen auf obgies Beispiel würde es z.B. Sinn machen, die jeweilige Form (1. Person Singular usw.) als Eigenschaft der jeweiligen Regelvariante mit anzugeben.

Beachten Sie die Beispiele zum Bilden von Regeln.

Wichtiger Hinweis: Auf ein Stichwort können auch mehrere Regeln angewendet werden!


word9f5k

Als weitere Datenbank öffnen

Das gleichzeitige Öffnen mehrerer Datenbanken ist nur mit der Wordbook-Viewer-Version möglich. Die Datenbanken werden über diese Funktion quasi miteinander verknüpft, so dass eine logische Sicht über mehrere Datenbanken hinweg möglich ist. Die verknüpften Datenbanken verhalten sich weitestgehend wie eine einzelne Datenbank. Dadurch ist es möglich:

- mehrere Datenbanken gleichzeitig zu öffnen und die enthaltenen Stichworte gemeinsam anzuzeigen,
- Suchfunktionen über mehrere Datenbanken hinweg durchzuführen,
- alle Ausgabefunktionen (Berichte, Drucken, Export) für mehrere Datenbanken auszuführen,
- Statistiken über mehrere Datenbanken durchzuführen,
- das Vokabeltraining über mehrere Datenbanken hinweg zu nutzen.

Bestimmte Funktionen beziehen sich immer auf die in der Titelleiste als 'aktive Datenbank' gekennzeichnete Datenbank. Die aktive Datenbank kann im Hauptfenster in der Funktionsleiste eingestellt werden.


word9f5l

Neue Eigenschaft/Neues Sachgebiet anlegen

Sie können beliebig viele neue Eigenschaften und Sachgebiete definieren und diese später Stichworten (oder im Fall von Wörterbüchern auch Entsprechungen) zuordnen.
Geben Sie dazu die neue Eigenschaft oder das neue Sachgebiet sowie eine zugehörige Abkürzung in die dafür vorgesehenen Texteingabefelder ein und bestätigen Sie das Hinzufügen. Die neu hinzugefügten Eigenschaften/Sachgebiete erscheinen anschließend in der angezeigten Auswahlliste.

Eigenschaften/Sachgebiete können auch aus einer TXT-Datei hochgeladen werden. Beachten Sie dabei, dass die Datei den folgenden Aufbau (mit Trennzeichen ; ) haben muss:

Eigenschaft1;Abkürzung1
Eigenschaft2;Abkürzung2
Eigenschaft3;Abkürzung3
usw.

oder:

Sachgebiet1;Abkürzung1
Sachgebiet2;Abkürzung2
Sachgebiet3;Abkürzung3
usw.

Beachten Sie, daß Sie auch Eigenschaften und Sachgebiete aus anderen Wordbook-Datenbanken importieren können!


word9f7a

Identische Einträge finden

Mit Hilfe dieser Funktion können Sie die in einer Wordbook-Datenbank mehrfach vorhandenen Einträge auffinden. Klicken Sie hierzu auf 'Suche starten'.

Sie können darüber hinaus mehrfach vorhandene Einträge zu einem Eintrag zusammenfassen.

Es existieren mehrere Optionen, welche Einträge zusammengefasst werden sollen.
1) Vergleich auf Basis des ganzen Feldinhaltes -> Mit dieser Option werden nur diejenigen Einträge zusammengefasst, die sich zu 100% entsprechen.
2) Vergleich auf Basis der ersten ... Zeichen -> Mit dieser Option werden diejenigen Einträge zusammengefasst, bei denen sich die ersten n Zeichen entsprechen. Der Wert für n kann geändert werden.

Zusätzlich kann auch noch angegeben werden, ob zwischen Groß- und Kleinschreibung differenziert werden soll.

Wordbook überprüft ausserdem bereits beim Eingeben von neuen Stichworten, ob diese bereits existieren, wenn Sie dies über die Konfiguration einstellen.


word9f7b

Vokabeltraining

Mit dieser Funktion (Extras -> Vokabeltraining) können Sie die Vokabeln eines Wörterbuches trainieren. Wählen Sie zunächst wieviele Vokabeln Sie trainieren möchten. Zu jeder Vokabel wird Ihnen eine bestimmte Anzahl von Entsprechungen (die Sie ebenfalls bestimmen können) vorgeschlagen.
Am Ende einer Trainingseinheit erhalten Sie die Lösung. Fehler können Sie durch anschließendes Training der entsprechenden Vokabeln sofort verbessern.

Alle Trainingsergebnisse werden in der aktuell geöffneten Datenbank gespeichert. Zum Vokabeltraining existiert ein Berichtswesen, mit dem Sie sich die Trainingsergebnisse in Berichtsform (als Liste und/oder Grafik) anzeigen lassen können.

Die Richtung können Sie beim Vokabeltraining auch umkehren (Entsprechung -> Stichwort trainieren)!

An Stelle von Stichworten können auch Beispiele und deren Übersetzungen trainiert werden (vorausgesetzt es sind Beispiele vorhanden).

Richtige Antworten merkt sich das Programm nach deren Häufigkeit. Bei künftigen Trainingsläufen können mehrfach richtige Vokabeln weggelassen werden. Falsche Antworten führen zu einer Rückstufung. Falsch beantwortete Vokabeln können explizit für das Training ausgewählt werden. Es können auch nur die Vokabeln der aktuellen Datenbank für das Vokabeltraining selektiert werden, die zuvor noch nie trainiert worden sind.

Es existiert eine Löschfunktion zum Zurücksetzen der Trainingsergebnisse.


word9f7c

Auswahl

Auswahl nach Eigenschaft/Sachgebiet
Stichworte können auch sortiert nach Eigenschaften/Sachgebieten angezeigt werden. Zu einer Liste der vorhandenen Eigenschaften bzw. Sachgebiete werden dann die Stichworte angezeigt, denen die betreffende Eigenschaft/das Sachgebiet zugeordnet ist.

Im Falle mehrerer geöffneter Datenbanken wird zusätzlich der Datenbankname angezeigt.

Auswahl nach Querverweis
Zu jedem Stichwort werden in dieser Ansicht die Querverweise angezeigt.

Die dargestellte Auswahl kann über die Pfeiltasten durchblättert werden.


word9f7d

Ansichten

Editierbare Ansichten
Wordbook bietet verschiedene tabellarische Übersichten zu einer Datenbank an, die sich auch editieren lassen.
Beim Editieren müssen Sie beachten, daß sich Änderungen von Eigenschaften und Sachgebieten (aus datenbanktechnischen Gründen) auf sämtliche Einträge mit der betreffenden Eigenschaft oder dem betreffenden Sachgebiet auswirken, auch wenn Sie dies zunächst nicht in allen Zeilen der Tabelle sehen können!

Falls mehrere Datenbanken geöffnet sind, so erfolgt die Änderung jeweils in der Datenbank, zu der das jeweilige Stichwort gehört.

Nicht editierbare Ansichten
Zu Übersichtszwecken lässt sich hier eine Ansicht aufrufen, die alle Informationen enthält.


word9f8w

Bericht drucken

Mit dieser Funktion können Sie die aktuelle Wordbook-Datenbank (bzw. auch mehrere geöffnete Datenbanken) ausdrucken.
Die Gestaltungsmöglichkeiten sind dabei fest und in engen Grenzen vordefiniert. So können Sie beispielsweise die Bildgrösse beeinflussen.

Sie können auswählen, welche Stichworte Sie drucken möchten. Die innerhalb von Wordbook üblichen Filterfunktionen können Sie ebenfalls auf den Ausdruck anwenden.

Weiterhin existiert eine Druckvorschau.

Für professionelle Layout-Zwecke ist die Exportmöglichkeit sowie die Funktion '
Bericht in Serienbrief-Steuerdatei ausgeben' vorgesehen.


word9f8x

Standardberichte

Unter diesem Menüpunkt besteht die Möglichkeit, vordefinierte Standardberichte zu erstellen. Die Berichte können nach verschiedenen Kriterien gruppiert werden. Ausserdem können Stichworte (z.B. Eigenschaften, Sachgebiete usw.) mit in den Bericht aufgenommen oder ausgeschlossen werden. Über Konfiguration können mit der neuen Programmversion weitreichende Einstellungen vorgenommen werden, so dass die Standardberichte flexibler als bisher formatiert werden können.
Beinflusst werden kann zum einen die Schriftart aller ausgegebenen Objekte. Zum anderen können auch der Einzug sowie der Abstand der Objekte zueinander eingestellt werden. Insgesamt ist somit eine hohe Flexibilität bei der Gestaltung der Berichtsausgabe gegeben.

Es kann weiterhin eingestellt werden, dass Abkürzungen für die Eigenschaften/Sachgebiete verwendet werden.

Es sind zudem verschiedene Layouts vorhanden, die sich für verschiedene Darstellungszwecke einsetzen lassen.

Durch die Möglichkeit mit Filtern zu arbeiten, kann der Umfang der Berichtsausgabe gezielt beeinflusst werden.

Die Berichte lassen sich über die vorhandenen Funktionen des Standardberichtsgenerators auch ausdrucken und in verschiedenen Formaten exportieren.


word9f8y

Bericht in Steuerdatei ausgeben

Diese Funktion erlaubt es Ihnen eine Datenbank in eine Steuerdatei auszugeben und anschließend die Steuerdatei in Verbindung mit einem Textverarbeitungsprogramm zur Erstellung eines papiergebundenen Wörterbuches in professionellem Layout (Mehrspaltensatz, usw.) zu nutzen. Zur Erreichung dieses Ziels sind mehrere Schritte erforderlich:

1. Erstellen der Steuerdatei
2. Aufruf der mitgelieferten Textverarbeitungs-Formatvorlage
3. Verbinden der Formatvorlage mit der Steuerdatei (dies entspricht dem Prinzip des Serienbriefs)

1. Erstellen der Steuerdatei

Wie beim Drucken können Sie auch hier wählen, welche Stichworte Sie in die Steuerdatei ausgeben möchten. Die Filter-Funktionen können Sie ebenfalls zur Auswahl einsetzen.
Sobald Sie 'Alle' oder einen 'Anfangsbuchstaben' ausgewählt haben, werden Sie nach dem Dateinamen gefragt unter dem die Steuerdatei gespeichert werden soll. Nach der Namenseingabe wird die Steuerdatei erstellt. Dies kann bei umfangreichen Datenbanken einige Zeit dauern!

2. Aufruf der Textverarbeitungs-Formatvorlage

Nun rufen Sie mit dem Textverarbeitungsprogramm eine mit Wordbook mitgelieferte Formatvorlage (im Ordner FORMATE) auf. Diese stellt eine Art von Schablone dar, die die Formatierungsmerkmale (Zeichen-, Absatzformatierung) für den späteren Ausdruck enthält. Die Formatvorlage enthält jedoch noch keine Daten. Deswegen müssen Sie die Formatvorlage anschließend mit der Steuerdatei (= Datendatei) verbinden.

3. Verbinden der Formatvorlage mit der Steuerdatei

am Beispiel von MS Word f. Windows:

- Wählen Sie nach Aufruf der Formatvorlage die Funktion 'Seriendruck'.
- Der Typ des Hauptdokuments muss 'Katalog' sein.
- Wählen Sie als Datenquelle die vorher erstellte Steuerdatei aus. Möglicherweise müssen Sie noch die verwendeten Steuerzeichen für die Feld- und Datensatztrennung angeben. Geben Sie die Zeichen an, die unter den Konfigurationseinstellungen angegeben sind.
- Starten Sie den Seriendruck in ein neues Dokument. Dies kann bei umfangreichen Datenbanken einige Zeit dauern!

für Wordperfect f. Windows:

- Oeffnen Sie zunaechst die mit Wordbook erstellte Steuerdatei mit Wordperfect. Beim Oeffnen werden Sie nach dem Konvertierungsformat gefragt. Geben Sie 'ANSI-Text mit Begrenzungszeichen (Windows)' an. Das Importformat kann 'Mischdatendatei' oder 'Tabelle' sein. Geben Sie als Begrenzungszeichen für die Feld- und Datensatztrennung jeweils die Zeichen an, die unter den Konfigurationseinstellungen angegeben sind. Speichern Sie die importierte Steuerdatei als Mischdatendatei (.DAT) ab.

- Wählen Sie nun die Funktion 'Mischen'.
- Geben Sie als Formulardatei die mit Wordbook mitgelieferte Formatvorlage an.
- Achten Sie darauf, dass beim Mischen kein Seitenumbruch nach jedem Datensatz stattfindet! Dies lässt sich über die Misch-Optionen in Wordperfect einstellen.
- Starten Sie den Mischvorgang. Dies kann bei umfangreichen Datenbanken einige Zeit dauern!

Als Endergebnis erhalten Sie ein formatiertes Wörterbuch. Das Erscheinungsbild können Sie nach Belieben verändern. Sie können auch eigene Formatvorlagen erstellen und diese mit der Steuerdatei kombinieren, sobald sie mit dem Prinzip vertraut geworden sind. Schauen Sie sich dazu am besten den Aufbau der mitgelieferten Muster-Formatvorlagen und auch das Beispiel in dieser Hilfedatei an und wandeln Sie diese nach Ihren Vorstellungen ab.


word9f8z

Eintrag in Zwischenablage kopieren

Diese Funktion kopiert den ausgewählten Eintrag mit allen Entsprechungen, Beispielen, Beispielübersetzungen, Eigenschaften und Sachgebieten, usw. in die Windows-Zwischenablage. Damit steht der Eintrag für andere Windows-Anwendungen zur Verfügung.


word9f74

Eigenschaften/Sachgebiete automatisch zuordnen

Sie können Eigenschaften und Sachgebiete automatisch neuen Stichworten und/oder Entsprechungen zuordnen lassen. Dies ist vor allem dann eine Arbeitserleichterung, wenn Sie über längere Zeit Stichworte zu einem bestimmten Sachgebiet eingeben oder nur Stichworte mit einer bestimmten Eigenschaft (z.B. nur Adjektive).

Wählen Sie dazu die angezeigte Eigenschaft oder das Sachgebiet aus und kreuzen Sie an, ob eine automatische Zuordnung zum Stichwort und/oder zur Entsprechung erfolgen soll. Ab sofort werden die ausgewählten Eigenschaften und/oder Sachgebiete für neue Stichworte automatisch vergeben.

Die aktuell automatisch zugeordneten Eigenschaften und Sachgebiete werden auf der Registerkarte 'Aktuelle Zuordnung' dargestellt.


word9f75

Eintrag suchen

Um nach einem Eintrag zu suchen, geben Sie zunächst einen Suchbegriff ein. Sie können auch nach einer Zeichenfolge oder nach dem Anfang eines Begriffs suchen. Die gewünschte Suchweise geben Sie zusätzlich an. Als letztes legen Sie noch den Suchbereich fest, der durchsucht werden soll.
Die gefundenen Einträge werden anschließend angezeigt und können durch Anklicken zur vollständigen Ansicht bzw. zum Bearbeiten ausgewählt werden.

Zusätzlich werden, soweit vorhanden, auch über- bzw. untergeordnete Stichworte angezeigt.

Gehe zu

Die Funktion 'Gehe zu' entspricht dem Suchen nach einem Begriffsanfang. Sobald Sie einen oder mehrere Buchstaben in das Eingabefeld eingeben, werden unterhalb die Stichworte mit den entsprechenden Anfangsbuchstaben angezeigt. Den gesuchten Begriff können Sie auswählen und mit allen Details anzeigen.

Es wird ausserdem angezeigt, zu welcher Datenbank das gefundene Stichwort gehört (diese Information ist von Interesse, falls mehrere Datenbanken geöffnet sind).

Hinweis: Da bei der Suche über verschiedene Felder nicht eindeutig festgelegt ist, ob nach einem Stichwort, nach einer Entsprechung oder innerhalb des Erläuterungsfeldes gesucht wird, kann beim Suchen (optional) eine Schriftart für das Eingabefeld eingestellt werden, um die Zeichen im Eingabefeld richtig darzustellen (dies ist nur dann erforderlich, wenn spezielle Schriftarten für Stichworte, Entsprechungen und/oder Erläuterungen verwendet werden).


word9f76

Nach Stichwörtern suchen

Innerhalb der von Wordbook angezeigten Stichworte, Entsprechungen, Beispiele, Beispielübersetzungen und Beschreibungen kann durch einen doppelten Mausklick auf die angezeigten Wörter im Anzeigefeld beliebig nach Begriffen bzw. ähnlichen Stichworten gesucht werden. Es wird - gleichzeitig - auf drei verschiedene Arten gesucht:

- nach exaktem Begriff, d.h. die Schreibweise muss exakt dem angeklickten Begriff entsprechen,

- nach ähnlichen Stichworten, d.h. es werden auch Stichworte mit ähnlicher Schreibweise wie der angeklickte Begriff gefunden,

- erweiterte Suche, d.h. es wird nicht nur nach Stichworten gesucht, sondern es wird zusätzlich innerhalb von Entsprechungen, Beispielen usw. nach Stichworten mit ähnlicher Schreibweise wie der angeklickte Begriff gesucht.

Zusätzlich werden, soweit vorhanden, auch über- bzw. untergeordnete Stichworte angezeigt.


word9f77

Statistik

Mit der Statistik-Funktion können sie die aktuelle Wordbook-Datenbank (bzw. auch übergreifend mehrere Datenbanken) statistisch auswerten. Die Statistik beantwortet Fragen wie:

- Wieviele Einträge sind in einem Wörterbuch/einer Enzyklopädie/einem Weblog enthalten?
- Wieviele Einträge mit einem bestimmten Anfangsbuchstaben sind enthalten?
- Wieviele Einträge mit einer bestimmten Eigenschaft sind enthalten?
- Wieviele Einträge zu einem bestimmten Sachgebiet sind enthalten?

usw.

Beachten Sie hierzu die Filter-Funktionen!


word9f78

Suchindex neu aufbauen/Sortierung neu aufbauen

Über diese beiden Funktionen können der Suchindex sowie die Sortierung neu aufgebaut werden. Dies ist normalerweise nicht erforderlich, da der Suchindex und die Sortierung automatisch aufgebaut werden. Manchmal kann es dennoch erforderlich sein, diese Funktionen auszuführen (z.B. nach dem Import von Stichworten, wenn noch kein Suchindex/keine Sortierung existiert).


word9f79

Einstellungen zur aktuellen Wordbook-Datenbank

Die Einstellungen können Sie über mehrere Registerkarten vornehmen:

Registerkarte 'Allgemein'

Hier können Sie einen Anzeigestil auswählen, der festlegt wie Wordbook die Daten im Anzeigefenster präsentieren soll. Auswählbar sind der 'Klassik-Stil' (Voreinstellung), der die Daten im Stil herkömmlicher Wörterbücher anzeigt, oder alternativ dazu der Wordbook-Stil.
Weiterhin kann (für Datenbanken des Typs 'Wörterbuch') festgelegt werden, ob die Entsprechungen zu einem Stichwort fortlaufend nummeriert werden sollen.
Eine weitere Funktion bietet die Möglichkeit, dass alle vorhandenen Entsprechungen bei der Neueingabe von Entsprechungen zu einem Stichwort im Bearbeitungsfenster angezeigt werden. Somit besteht die Möglichkeit, bereits vorhandene Entsprechungen zu einem neuen Stichwort per Doppelklick direkt bei der Stichwort-Eingabe zu übernehmen.

Weiterhin geben Sie hier eine Kurzbeschreibung für das Wörterbuch/die Enzyklopädie ein.
Sie können außerdem anhand einer Prüfung für das Eingeben neuer Stichworte einstellen, ob Stichworte bereits in der Datenbank existieren.
Ausserdem legen Sie fest, ob für Eigenschaften und Sachgebiete die entsprechenden Abkürzungen verwendet werden sollen.
Beachten Sie, daß letztere Einstellungsmöglichkeit weitreichende Folgen hat, da auch beim Ausdruck von Wörterbüchern nun die Abkürzungen verwendet werden!

Für Weblog-Datenbanken stellen Sie hier das standardmässig verwendete Datumsformat ein.
Voreingestellt ist als Datumsformat die Zeichenfolge d. mmmm yyyy, hh:mm:ss (dddd). Dieses Datumsformat kann - unter Beachtung der für das Datumsformat gültigen Regeln (d = Tag, m = Monat usw.) -beliebig angepasst werden.
Ausserdem kann prinzipiell zwischen der Verwendung als Datenbank vom Typ "Enzyklopädie" oder "Weblog" umgeschaltet werden.

Zur Speicherung der mit Wordbook angelegten Datenbanken kann hier ein Standard-Ordner definiert werden. Voreingestellt ist das Verzeichnis AppData\Roaming\Wordbook. Der Standard-Ordner wird als Voreinstellung beim Öffnen/Speichern von Wordbook-Datenbank-Dateien verwendet.

Registerkarte 'Sprache'

Hier stellen Sie die Übersetzungsrichtung sowie Schriftarten für die jeweilige Sprache ein.

Registerkarte 'Audio'

Hier nehmen Sie Einstellungen für die Vertonung von Stichworten vor (kHz, bit, 1 oder 2-Kanal). Beachten Sie, daß qualitativ hochwertige Auflösungen um ein Vielfaches mehr Speicherplatz benötigen! In der Regel reicht jedoch eine geringe Aufnahmequalität (Voreinstellung) aus.
Ausserdem können Sie hier den Pfad angeben, in dem Wordbook die vertonten Stichworte (sowie auch Bilder) speichert. Wordbook verwendet diesen Pfad, um vertonte Stichworte und auch Bilder wiedergeben zu können. Sollten Sie aus irgendwelchen Gründen das Audio-/Bildverzeichnis eines Wörterbuchs verschieben, so müssen Sie den zugehörigen Pfad korrigieren! Ansonsten kann Wordbook die Vertonungen und Bilder nicht wiederfinden.

Registerkarte 'Sortierreihenfolge/Alfabet'

Diese Registerkarte dient der Einstellung der Sortierreihenfolge der aktuellen Datenbank. Beachten sie, daß Sie die Datenbank nach Änderung der Sortierreihenfolge kompaktieren müssen, um die Änderung wirksam werden zu lassen!

Die aufgelisteten Alfabetzeichen beeinflussen die Filterung. Bsp.weise werden alle Stichworte, die mit 'Ä' beginnen unter 'A' einsortiert. Sie können die Tabelle für ihren Zweck abändern oder ergänzen.

Registerkarte 'Ausgabe-Texte'

Die hier aufgelisteten Texte werden bei der Ausgabe am Bildschirm sowie beim Drucken verwendet. Sie können die Texte auch ändern.

Registerkarte 'Lautschrift' (nur bei Wörterbüchern)

Hier können Sie eine beliebige Schriftart auswählen, die von Wordbook als Lautschrift verwendet werden soll. Spezielle, für Lautschrift geeignete
Schriftarten finden sich beispielsweise im Internet. In Wordbook als Lautschrift voreingestellt ist Arial Unicode MS.
Für die ausgewählte Lautschrift sind jeweils Zeichen in einer Textbox hinterlegt. Die dort eingegeben Zeichen stehen beim Anlegen von
Stichworten als Eingabehilfe zur Verfügung. Die benötigten Zeichen können von Ihnen selbst gepflegt werden; dies ist insbesondere dann
erforderlich, wenn Sie eine andere Schriftart als Lautschrift verwenden..

Registerkarte 'Web-Berichts-Ausgabe'

Hier kann eine Reihe von Einstellungen vorgenommen werden, die bei der Web-Berichtsausgabe verwendet wird.
- Absolute Pfade des Dateisystems verwenden: Diese Einstellung eignet sich nur zur lokalen Nutzung auf ihrem PC.
- Absolute Pfade der angegebenen Website verwenden: Idealerweise sollte diese Einstellung gewählt werden, wenn die generierten HTML-, XML- oder RSS-Seiten im Web veröffentlicht werden sollen. Es muss dann allerdings eine Website angegeben werden (siehe Registerkarte 'Autor').
- Relative Pfade verwenden: Diese Einstellung kann alternativ ebenfalls für die Webausgabe verwendet werden.

Beachten Sie beim Veröffentlichen, dass ausgehend von einem Verzeichnis, in dem sich die HTML-Seiten befinden, ein weiteres Verzeichnis, das die Bilder und Audio-Dateien enthält, sich unmittelbar im Hauptverzeichnis befinden muss. Ausserdem werden zwei relative Verzeichnisse 'Images' und 'Stylesheets' benötigt, die sich ebenfalls unmittelbar im Hauptverzeichnis befinden müssen. In diesen Verzeichnissen müssen sich die verwendeten Icons (News, Rating) und die verwendeten Stylesheets befinden.

HTML-/Linkeinstellungen:

- Bild mit URL verknüpfen: Falls ein Bild sowie eine URL vorhanden sind, so wird für das Bild die vorhandene URL als aktiver Link hinterlegt

- Stichwort bei Bildern als ALT-Text ausgeben: Falls ein Bild vorhanden ist, so wird das Stichwort (der Stichworttext) alternativ als Text in der erzeugten HTML-Seite angezeigt

- New-Icon anzeigen: Für neue Datenbank-Einträge wird beim Publizieren als HTML-Datei ein New-Icon angezeigt. Es kann zudem die Anzahl der tage eingestellt werden, ab denen ein Eintrag als 'Neu' gilt.

- Rating anzeigen: Falls für URL-Einträge ein 'Rating'-Wert vergeben wurde (= Bewertung der Qualität), so kann dieses Rating bei der HTML-Ausgabe mit veröffentlicht werden. Die vergebenen Bewertungen werden in Form von Sternchen ( *** ) angezeigt.

- URL separat anzeigen: Die URL kann zusätzlich in Textform als aktiver Link angezeigt werden.

- Verwendetes Stylesheet: Über ein Stylesheet kann die Formatierung der HTML-Ausgabe gesteuert werden. Es werden mehrere Stylesheets mit Wordbook mitgeliefert, die Sie zusätzlich auch selbst anpassen können.

Registerkarte 'Druckschriften'

Für jedes Element einer Wordbook-Datenbank (Stichworte, Entsprechungen, Eigenschaften, Sachgebiete, Beispiele usw.) kann hier eine eigene Druckschrift eingestellt werden. Die hier getätigten Einstellungen werden beim Drucken von Berichten sowie auch bei der Ausgabe von Standardberichten (hier jedoch ohne Berücksichtigung der Farbeinstellung) verwendet.

Beachten Sie, dass Änderungen der vorgegebenen Standard-Druckschriften möglicherweise zu unerwünschten bzw. unvorhersehbaren Druckergebnissen führen können.

Registerkarte 'XML-Ausgabe'

Über ein Stylesheet kann die Formatierung der XML-Ausgabe gesteuert werden. Es werden mehrere XML-Stylesheets mit Wordbook mitgeliefert, die Sie zusätzlich auch selbst anpassen können. Beachten Sie, dass bei der XML-Ausgabe das Häkchen 'Stylesheet verwenden' gesetzt sein muss.

Registerkarte 'Steuerdatei-Ausgabe'
Hier können Sie die Einstellung für die verwendeten Steuerzeichen für die Ausgabe in eine Steuerdatei ändern. Grundsätzlich müssen Zeichen verwendet werden, die innerhalb der auszugebenden Datenbank sonst nicht vorkommen. Standardmäßig sind die Zeichen ^ für die Datenfeldtrennung und ~ für die Datensatztrennung eingestellt. Beachten Sie hierzu auch die Beschreibung zum Vorgehen bei der Ausgabe in eine Steuerdatei.

Registerkarte 'Autor'
Hier werden die Einstellungen gepflegt, die für die RSS-Ausgabe verwendet werden. Die folgenden Angaben können gemacht werden:

Autor, z.B. Vorname, Nachname
Copyright-Hinweis, z.B. Copyright ... Jahr
Web-Adresse, z.B. www.domain.de
E-Mail-Adresse, z.B. Name@domain.de

Registerkarte 'Standardberichte'
Hier können spezifische Einstellungen für die Ausgabe der Standardberichte gemacht werden. Mit diesen Einstellungen kann die Ausgabe der Objekte in den Standardberichten beeinflusst werden. U.a. kann der Absatzeinzug sowie der Abstand vor und nach einem Objekt eingestellt werden. Insgesamt können die Standardberichte damit individueller als bisher formatiert werden. Über ‘Zurücksetzen’ können die ursprünglichen Einstellungen wieder hergestellt werden.

Das Feld ‘Letzte Aktualisierung Report-Tabellen’ zeigt das Datum an, zu dem die Report-Tabellen das letzte Mal aktualisiert worden sind. Dieses Datum kann auch manuell verändert werden. Normalerweise ist dies nicht erforderlich. Es kann aber Sinn machen, wenn z.B. die Funktion ‘Report-Tabellen aktualisieren’ (zu finden unter Extras -> Dienstprogramme) ab einem bestimmten Datum ausgeführt werden soll.

Registerkarte 'Sortieroptionen'
Auf dieser Registerkarte kann das Sortierverhalten (Alfabetisierung) beeinflußt werden. Grundsätzlich geht es hierbei darum, in welcher Reihenfolge die Stichworte innerhalb von Wordbook sowie z.B. auch bei der Ausgabe in den Berichten, usw. ausgegeben werden. Es können z.B. bestimmte Sonderzeichen, die am Beginn eines Stichwortes stehen können, von der Sortierung ausgeschlossen werden. Es würde dann z.B. das spanische ¿qué? unter dem Buchstaben q einsortiert werden (das vorangestellte ¿ wird von der Sortierung ingnoriert). Eine weitere Möglichkeit besteht darin, hier die zusammen mit Stichworten verwendeten Artikel zu hinterlegen. Die bei der Stichworteingabe vorangestellten Artikel werden dann von der Sortierung (Alfabetisierung) ausgeklammert. Beispielsweise würde der italienische Begriff la bambina dann unter dem Buchstaben b einsortiert werden (der vorangestellte Artikel la wird von der Sortierung ignoriert). Bei der Stichworteingabe ist dabei zu beachten, dass zwischen Artikel und dem eigentlichen Stichwort immer ein Leerzeichen erwartet wird. Wenn kein trennendes Leerzeichen eingegeben wird, kann der vorangestellte Artikel nicht erkannt werden. Dies ist insbesondere bei Artikelformen wie l’ (z.B. in l’ acqua) zu beachten.


word9f90

Bild in Zwischenablage kopieren

Mit dieser Funktion kann das zu einem ausgewählten Eintrag gehörige Bild in die Windows-Zwischenablage kopiert werden.


word9f91

Einträge umhängen

Einträge in Wordbook können mit dieser Funktion umgehängt, d.h. einem anderen Eintrag zugeordnet, werden. So können auch nachträglich Stichworte strukturiert werden (z.B. können Wortfamilien zusammengefasst werden). Die Funktion bezieht sich jeweils auf den aktuell ausgewählten Eintrag.
Ausserdem können untergeordnete Einträge der zweiten Ebene wieder auf die 1. Ebene zurückgestuft werden.


word9f92

Eigenschaften/Sachgebiete löschen

Mit Hilfe dieser Funktion können vorhandene Eigenschaften/Sachgebiete zu Stichworten und/oder Entsprechungen gelöscht werden. Es werden nur die Eigenschaften und Sachgebiete gelöscht, die im Dialog ausgewählt wurden. Sobald der Löschvorgang gestartet wird, werden die ausgewählten Eigenschaften/Sachgebiete von allen Stichworten bzw. Entsprechungen in der aktiven Datenbank entfernt.
Hinweis: Die Stichworte und Entsprechungen werden dabei nicht gelöscht. Die zum Löschen ausgewählten Eigenschaften und Sachgebiete sind noch vorhanden; sie müssen jedoch wieder neu zu Stichworten und Entsprechungen hinzugefügt werden.


word9f93

Import von Eigenschaften/Sachgebieten

Sie können Eigenschaften und Sachgebiete aus anderen Wordbook-Datenbanken importieren. Hierzu müssen Sie zunächst die Quell-Datenbank angeben, aus der Sie die Eigenschaften oder Sachgebiete importieren wollen.
Als nächstes erhalten Sie eine Übersicht, welche Eigenschaften bzw. Sachgebiete zum Import vorhanden sind und welche iin der akktuellen Wordbook-Datenbank bereits existieren. Sie können entweder alle Eigenschaften bzw. Sachgebiete importieren oder einzelne Eigenschaften bzw. Sachgebiete übernehmen.


word9f94

Import aus anderen Wordbook-Datenbanken

Mit dieser Funktion können mit Wordbook erstellte Wörterbücher oder Enzyklopädien/Weblogs importiert werden. Hierzu geben Sie zunächst das zu importierende Wörterbuch bzw. die Enzyklopädie/das Weblog (= Quell-Datenbank) an. Anschließend können Sie die zu importierenden Stichworte (Stichworte, Entsprechungen,...) auswählen. Der Import von umfangreichen Wordbook-Datenbanken kann einige Zeit dauern!

Ab Version 2014.03 wurde diese Funktion überarbeitet und verbessert. Es sind nun 2 verschiedene Import-Verfahren möglich:

1. Ohne Zusammenführen von Stichwörtern
Bei diesem Verfahren bleiben Stichwörter, die sowohl in der zu importierenden Wordbook-Datenbank als auch in der Ziel-Datenbank identisch vorhanden sind, mit allen Zuordnungen (Entsprechungen, Eigenschaften, Sachgebiete, usw.) erhalten.

2. Zusammenführen vorhandener Stichwörter
Bei diesem Verfahren werden identische Stichwörter, die sowohl in der zu importierenden Wordbook-Datenbank als auch in der Ziel-Datenbank vorhanden sind, zu einem Stichwort zusammengeführt. Alle Zuordnungen (Entsprechungen, Eigenschaften, Sachgebiete, usw.) aus Import- und Ziel-Datenbank werden dabei zu einem einzigen Stichwort zugeordnet.

Beispiel:

Geöffnete Ziel-Datenbank:

Stichwort | Entsprechung | Eigenschaften zum Stichwort | Sachgebiete zum Stichwort
A | Entsprechung A1 | Eigenschaft A1 | Sachgebiet A1
B | Entsprechung B1 | Eigenschaft B1 | Sachgebiet B1

Zu importierende Datenbank:

Stichwort | Entsprechung | Eigenschaften zum Stichwort | Sachgebiete zum Stichwort
A | Entsprechung A2 | Eigenschaft A2 | Sachgebiet A2
C | Entsprechung C1 | Eigenschaft C1 | Sachgebiet C1

1. Ergebnis nach Import (ohne Zusammenführen von Stichwörtern):

Stichwort | Entsprechung | Eigenschaften zum Stichwort | Sachgebiete zum Stichwort
A | Entsprechung A1 | Eigenschaft A1 | Sachgebiet A1
A | Entsprechung A2 | Eigenschaft A2 | Sachgebiet A2
B | Entsprechung B1 | Eigenschaft B1 | Sachgebiet B1
C | Entsprechung C1 | Eigenschaft C1 | Sachgebiet C1

2. Ergebnis nach Import (mit Zusammenführen von Stichwörtern):

Stichwort | Entsprechung | Eigenschaften zum Stichwort | Sachgebiete zum Stichwort
A | Entsprechung A1 Entsprechung A2 | Eigenschaft A1 Eigenschaft A2 | Sachgebiet A1 Sachgebiet A2
B | Entsprechung B1 | Eigenschaft B1 | Sachgebiet B1
C | Entsprechung C1 | Eigenschaft C1 | Sachgebiet C1

Beachten Sie beim Import von Audio- und Bild-Dateien folgendes:

Die Audio- und Bild-Dateien werden von Wordbook automatisch vom Audio-Bild-Dateien-Ordner der Import-Datenbank in den Audio-Bild-Dateien-Ordner der aktuellen Datenbank kopiert. Das aktuelle Audio-Bild-Dateien-Verzeichnis ist unter Konfiguration->Einstellungen angegeben und auch ändernbar, falls sie diesen Ordner z.B. umbenennen oder verschieben wollen.

Tipp:
Durch die Importmöglichkeit ganzer Wordbook-Datenbanken können Sie bei der Erstellung von Wörterbüchern und Enzyklopädien/Weblogs auch arbeitsteilig vorgehen:

Erstellen Sie zunächst einzelne Abschnitte innerhalb getrennter Datenbanken. Dies kann natürlich auch durch verschiedene Bearbeiter an unterschiedlichen Arbeitsplätzen geschehen.
Anschließend importieren Sie die Teilarbeiten in eine Gesamtversion.
Dieses Vorgehen ist auch dann zu empfehlen, wenn ein Wörterbuch/eine Enzyklopädie bereits sehr umfangreich geworden ist und sich deswegen - abhängig von der vorhandenen Rechnerleistung - eventuell der Zugriff bei bestimmten Funktionen verlangsamt. In einem solchen Fall können Sie mit mehreren Datenbanken arbeiten und diese später über die Importfunktion zusammenführen.


word9f95

Import aus externen Datenbanken

Wordbook bietet die Möglichkeit Stichworte aus externen Datenbanken oder Text (in Listenform) zu importieren.
Die folgenden Importformate kommen hierfür in Frage:

Text
Access
dBaseIII
dBaseIV
Paradox 3.x
Paradox 4.x
FoxPro 2.0
FoxPro 2.5
Foxpro 2.6
FoxPro 3.0
Excel 3.0
Excel 4.0
Excel 5.0/95
Excel 97
Lotus 1-2-3 WK1/WKS
Lotus 1-2-3 WK3
Lotus 1-2-3 WK4

Desweiteren können beliebige ODBC-Datenquellen (z.B. MS SQL Server, Oracle, ...) importiert werden.

Beim Import externer Datenquellen gehen Sie wie folgt vor:

Für Wörterbücher:

1. Auswahl der Datenquelle (Datei -> Importieren -> Externe Daten importieren -> ...)
2. nur bei Datenbanken: Auswahl der Tabelle/Abfrage
3. Auswahl der Spalte, die die Stichworte enthält
4. Auswahl der Spalte, die die Entsprechungen enthält
5. Auswahl der Spalte, die Bemerkungen zum Stichwort enthält (optional)
6. Zuordnung von Eigenschaften/Sachgebieten (optional)
7. Start des Importvorgangs

Für Enzyklopädien/Lexika:

1. Auswahl der Datenquelle (Datei -> Importieren -> Externe Daten importieren -> ...)
2. nur bei Datenbanken: Auswahl der Tabelle/Abfrage
3. Auswahl, dass Beschreibungen importiert werden sollen
4. Auswahl der Spalte, die die Stichworte enthält
5. Auswahl der Spalte, die die Beschreibungen/Texte enthält
6. Zuordnung von Eigenschaften/Sachgebieten (optional)
7. Start des Importvorgangs

Für Linksammlungen:

1. Auswahl der Datenquelle (Datei -> Importieren -> Externe Daten importieren -> ...)
2. nur bei Datenbanken: Auswahl der Tabelle/Abfrage
3. Auswahl, dass URLs importiert werden sollen
4. Auswahl der Spalte, die die Stichworte enthält
5. Auswahl der Spalte, die die URLs enthält
6. Auswahl der Spalte, die die URL-Bezeichnungen enthält
7. Auswahl der Spalte, die die URL-Kurzbeschreibungen enthält (optional)
8. Zuordnung von Eigenschaften/Sachgebieten (optional)
9. Start des Importvorgangs

Beim Import werden eventuell vorhandene führende Leerzeichen entfernt. Zudem findet eine Überprüfung statt, ob die zu importierenden Daten den von Wordbook gestellten Anforderungen entsprechen. Es dürfen bspw. keine Stichworte importiert werden, die mehr als 250 Zeichen umfassen.
Grundsätzlich ist es sehr wichtig, den Import gut vorzubereiten, um Fehler beim Import zu vermeiden. Hierzu gehört bspw. die Überprüfung der zu importierenden Datei auf Leerzeilen, unerlaubte Zeichen (z.B. ") usw.
Idealerweise sollten die zu importierenden Informationen in einem geeigneten Datenformat und spaltenweise aufbereitet vorliegen. Ungeeignet sind hingegen zusammenhängende Texte, in denen beispielsweise Stichwörter und Entsprechungen nicht eindeutig voneinander getrennt sind.

Der Import umfangreicher Datenmengen kann einige Zeit dauern!

Tipp:
Sie können mit Hilfe eines OCR-Programms auch papiergebundene Wörterlisten einscannen und diese als Textdatei (.TXT) abspeichern. Das Speicherungsformat sollte wie folgt aussehen:

Begriff1 ; Entsprechung; (Bemerkung)
Begriff2 ; Entsprechung; (Bemerkung)
Begriff3 ; Entsprechung; (Bemerkung)
...

Anschliessend können Sie die Textdatei in Wordbook importieren.

Folgendes ist weiterhin zu beachten:
- In der Vorschau der zu importierenden Daten wird jeweils die eingestellte Schriftart für Stichworte, Entsprechungen und Bemerkungen verwendet.
- Der Import von Bemerkungen ist optional, d.h. es muss nicht zwingend eine Spalte zum Import ausgewählt werden.
- Beim Import von Textdateien wird ein Dialogfenster geöffnet, in dem als Vorbereitung für den Import verschiedene Angaben zu tätigen sind:
- Verwendetes Trennzeichen in der Textdatei (z.B. ; oder ,)
- Existenz von Spaltenüberschriften
- Trennzeichen für Dezimalzahlen (. ist normalerweile die richtige Einstellung)
- Dateiformat (ANSI, OEM, UTF-8, Unicode)

- Achten Sie darauf, dass das verwendete Spaltentrennzeichen innerhalb des gesamten Dateinhalts nicht vorkommt (außer als Trennzeichen), da es sonst als Trennzeichen interpretiert wird!


word9fao

Übersetzungsrichtung umkehren

Diese Funktion ermöglicht es, das aktuell geöffnete Wörterbuch (z.B. Deutsch-Englisch) als neue Datenbank mit umgekehrter Übersetzungsrichtung (z.B. Englisch-Deutsch) abzuspeichern.
Dabei ist folgendes zu beachten:

- alle Stichworte und Entsprechungen (auch die der untergeordneten Ebenen) werden als Einträge der ersten Ebene gespeichert (nicht als untergeordnete Folgeebenen),
- falls einem Stichwort mehrere Entsprechungen zugeordnet sind, so ergeben sich daraus nach der Invertierung mehrere Stichworte, denen jeweils eine Entsprechung zugeordnet ist,

- Eigenschaften und Sachgebiete werden ebenfalls invertiert,
- Beispiele und Beispielübersetzungen werden gleichfalls invertiert.


word9fap

Datenbank exportieren

Mit dieser Funktion können Sie Wörterbücher oder Enzyklopädien/Weblogs in viele Formate exportieren. Der Export-Datei müssen Sie einen Dateinamen geben.
Tipp:
Beachten Sie, daß Sie die exportierte Datenbank dazu nutzen können, professionelle Wörterbücher oder Online-Wörterbücher für das World Wide Web zu erstellen.
Die Datenbank muss dazu mit Hilfe entsprechender Tools an das WWW angebunden werden.
Sie können auch ein Textverarbeitungsprogramm verwenden, wie es in Verbindung mit der Steuerdatei beschrieben ist.

Die folgenden Exportformate werden unterstützt:

MS Access
Beim Export nach MS Access wird eine Access-Datenbank angelegt, die eine Tabelle 'WordbookExportFile' enthält. In dieser Tabelle werden sämtliche Informationen gespeichert.
Zu beachten ist folgendes: Die Tabellenspalten OBJECTID und OBJECTID1 geben - insofern sich deren Werte unterscheiden - die Beziehung zwischen Stichworten der 1. Ebene und Stichworten der untergeordneten Ebene an. Sie finden zudem als Beispiel eine Abfrage, die die Möglichkeit der Tabellenverknüpfung demonstriert.

Text
Textformat. Speichert die Daten im Textformat; es kann ein Trennzeichen sowie eine Zeichensatz-Einstellung vorgegeben werden.

CSV
CSV-Format. Speichert die Daten im CSV-Format; es kann ein Trennzeichen sowie eine Zeichensatz-Einstellung vorgegeben werden.

Excel
Exportiert den Bericht als Microsoft Excel -Tabelle.

Paradox

ODBC


word9faq

Datenbank kompaktieren

Es gibt 2 Gründe eine Datenbank zu kompaktieren:

1. Durch das Kompaktieren wird unnötig belegter Speicherplatz freigegeben.
2. Wenn Sie unter Extras->Einstellungen die Sortierreihenfolge geändert haben, müssen Sie die Datenbank anschließend kompaktieren, um die Änderungen wirksam werden zu lassen.


word9far

Datenbank reparieren

Mit dieser Funktion können Sie versuchen eine beschädigte Datenbank zu reparieren.


word9fas

Datenbank sichern

Vor dem Sichern muß die aktuelle Datenbank geschlossen werden.
Im folgenden Dialog kann ein Pfad/Ordner zur Erstellung der Datenbanksicherung angegeben werden. Es wird empfohlen, hier ein anderes Laufwerk als den Speicherort der Original-Datenbank zu verwenden.
Anschließend wird eine Sicherung der Datenbank erstellt, die mit im Dateinamen angehängtem Datum und Uhrzeit der Sicherung im angegebenen Ordner gespeichert wird.Bilddateien, Audiodateien und sonstige angehängte Dateien können wahlweise in einen separaten Ordner mitgesichert werden.
Der Sicherungsname ist bei der Funktion ‘Datenbanksicherung’ nicht frei wählbar. Um eine Datenbankkopie mit frei wählbarem Dateinamen zu erstellen, kann die Funktion Datenbankkopie erstellen verwendet werden.

Tipp:
Sie sollten Ihre Wordbook-Datenbanken möglichst regelmässig sichern, um Datenverlusten vorzubeugen!


word9fat

Eigene Formatvorlagen erstellen

Sie können Wordbook zur Erstellung von Wörterbüchern zusammen mit beliebigen
Textverarbeitungsprogrammen einsetzen. Dazu müssen Sie eine Formatvorlage
verwenden, die mit den aus Wordbook stammenden Daten kombiniert wird. Der
Aufbau einer solchen Formatvorlage wird aus den mitgelieferten
Beispielformatvorlagen ersichtlich und ist unten abgebildet (für Word). Sie können die
mitgelieferten Formatvorlagen entweder nach Ihren Vorstellungen anpassen oder Ihre
eigenen Formatvorlagen erstellen.

Für Wordperfect kann eine entsprechende Formatvorlage nach folgendem Muster
aufgebaut werden:

If (feld(2)=object) feld(1)
else if (feld(2)=pronunciation)feld(1)
else if (feld(2)=note)feld(1)
else if (feld(2)category_object)feld(1)
else if (feld(2)field_object)feld(1)
else if (feld(2)meaning)feld(1)
else if (feld(2)category_meaning)feld(1)
else if (feld(2)field_meaning)feld(1)
else if (feld(2)example)feld(1)
else if (feld(2)example_translation)feld(1)

else if (feld(2)crosslink)feld(1)
...


word9fau

Beispiel für Eigenschaften und Eigenschaftswerte

Sie können Eigenschaften zu Stichworten oder - im Fall von Wörterbüchern - auch
Entsprechungen zuordnen. Für jede Eigenschaft können Sie einen Eigenschaftswert
angeben. Im Folgenden ein Beispiel:

Ausgegangen wird von einem Projekt eines Lexikons zum Thema "Länder der Erde".
Für dieses Lexikon wird u.a. die folgende Struktur bestimmt:

Stichwort: Land (z.B. Deutschland)
Erläuterung: Beschreibender Text

Eigenschaft: Eigenschaftswert (für Deutschland)

Landesfläche 357.588 Quadratkilometer
Einwohnerzahl 84,2 Millionen
Haupstadt Berlin
Sprache Deutsch
Währung Euro
......


word9fav

Beispiel zu Querverweisen

Eine wichtige Funktion innerhalb von Enzyklopädien stellen thematische
Querverweise dar. Wordbook unterstützt dieses Erstellen von Querverweisen durch
eine weitreichende Automatisierung. Der Anwender kann hierbei verschiedene
Konfigurationen vornehmen; z.B. welche Texte und Stichworte die Grundlage für die
Querverweise darstellen sollen. Querverweise können natürlich auch manuell
hinzugefügt werden.

So sollen z.B. zu einem Text, der die Begriffe 'Schloss', 'Schlosstor', 'Schlossturm',
'Schlosshof' und 'Schlosshund' enthält, entsprechende Querverweise auf diese
Begriffe in der Enzyklopädie hergestellt werden. Da sich die Übereinstimmung
lediglich auf den Teilbegriff 'Schloss' bezieht, muss für das Generieren von
Querverweisen folgendes eingestellt werden:

- Anzahl der Vergleichszeichen: 7
- Beginnend ab dem Zeichen: 1
- Nur ganze Begriffe: Nicht angekreuzt

Zusätzlich kann eingestellt werden, welche Texte für den Aufbau von Querverweisen
durchsucht werden sollen (z.B. nur Stichworte oder zusätzlich auch Erläuterungstext usw.).


word9faw

Beispiele zu Regeln

Regeln können immer dann eingesetzt werden, wenn es darum geht, immer
wiederkehrende Formen innerhalb einer Sprache abzubilden. Dies ist
beispielsweise oft für verschiedene Verbformen der Fall (Konjugationsformen),
jedoch auch in anderen Fällen, z.B. bei der Bildung des Plurals.

Die folgenden Beispiele sollen helfen, die Anwendung von Regeln zu verstehen:

1. Plural männlicher Substantive mit Endung auf Konsonanten im
Spanischen

Die Regel lautet: Die Pluralform von Substantiven, die auf Konsonanten enden,
wird durch Anhängen von -es an die Singularform gebildet. Bei männlichen
Substantiven wird zudem der Artikel 'los ' dem Substantiv vorangestellt.

Vorgehen, um diese Regel mit Wordbook abzubilden:

1) Erstellen Sie eine neue Regel.
2) Geben Sie dieser Regel einen Namen, z.B. Plural männl. Substantive mit
Endung auf Konsonant
3) Geben sie an, ob durch die Regel ein Unterbegriff erzeugt oder das
Beschreibungsfeld für die durch die Regelanwendung erzeugten Begriffe genutzt
werden soll.
4) Geben Sie als Anzahl der Regelvarianten ein: 1
5) Geben Sie als 'Zeichenfolge, die dem Stichwort vorangestellt werden soll' ein: los
(den Artikel + ein Leerzeichen)

6) Geben Sie als 'Zeichenfolge, die dem Stichwort nachgestellt werden soll' ein: es
Optional: Ordnen sie der Regelvariante ein oder mehrere Eigenschaften und/oder
Sachgebiete zu (z.B. Plural, männlich)
7) Beenden Sie die Regeldefinition.

Anschliessend können Sie die neue Regel auf jeden passenden Begriff
anwenden. Dies geschieht über die Registerkarte 'Regel' beim Neuanlegen oder
Bearbeiten von Stichworten:

1) Wählen Sie die Regel aus.
2) Klicken Sie auf 'Anwenden'.

Die Regel erzeugt zu jedem Begriff auf den sie angewendet wird genau einen
weiteren Begriff:

hotel -> los hoteles
ciudad -> los ciudades
usw.

2. Präsens Indikativ der Verben auf -er im Spanischen

Die Regel lautet: Ausgehend vom Stamm des Verbes werden die
Konjugationsformen durch Anhängen der folgenden 6 Endungen gebildet:

-o
-es
-e
-emos
-éis
-en

Vorgehen, um diese Regel mit Wordbook abzubilden:

1) Erstellen Sie eine neue Regel.

2) Geben Sie dieser Regel einen Namen, z.B. Präsens Indikativ der Verben
auf -er
3) Geben sie an, ob durch die Regel ein Unterbegriff erzeugt oder das
Beschreibungsfeld für die durch die Regelanwendung erzeugten Begriffe genutzt
werden soll.
4) Geben Sie als Anzahl der Regelvarianten ein: 6
5) Klicken Sie auf Weiter und geben Sie nun die erste Regelvariante ein:
- Zeichenfolge, die dem Stichwort vorangestellt werden soll' ein: yo (mit einem
abschliessenden Leerzeichen)

- Zeichenfolge, die andere Zeichen des Stichwortes ersetzen soll: o (mit einem
abschliessenden Leerzeichen)
- Auswahl von: Ersetze letzte
- Anzahl zu ersetzender Zeichen: 2
Optional: Ordnen sie der Regelvariante ein oder mehrere Eigenschaften und/oder
Sachgebiete zu (z.B. 1. Person Singular)
6) Klicken Sie auf Weiter und geben Sie nun die zweite Regelvariante ein:
- Zeichenfolge, die dem Stichwort vorangestellt werden soll' ein: tu (mit einem
abschliessenden Leerzeichen)

- Zeichenfolge, die andere Zeichen des Stichwortes ersetzen soll: es
- Auswahl von: Ersetze letzte
- Anzahl zu ersetzender Zeichen: 2
Optional: Ordnen sie der Regelvariante ein oder mehrere Eigenschaften und/oder
Sachgebiete zu (z.B. 2. Person Singular)

... verfahren Sie analog für die Regelvarianten 3 bis 6, um die weiteren Verbformen
als Regel abzubilden ...

7) Beenden Sie die Regeldefinition.

Anschliessend können Sie die neue Regel auf jeden passenden Begriff
anwenden. Dies geschieht über die Registerkarte 'Regel' beim Neuanlegen oder
Bearbeiten von Stichworten:

1) Wählen Sie die Regel aus.
2) Klicken Sie auf 'Anwenden'.

Die Regel erzeugt zu jedem Begriff auf den sie angewendet wird genau 6 weitere
Begriffe:

comer
-> yo como
-> tu comes
-> el/ella come
-> nosotros comemos
-> vosotros coméis
-> ellos/ellas comen

usw.

3. Präsens Indikativ der Verbgruppe e/ie mit Endung -er im Spanischen

Die Regelbildung erfolgt hier wie beim obigen Beispiel, mit dem Unterschied, dass
zusätzlich für einige Formen e durch ie ersetzt werden muss.

Ein Beispiel stellt das Verb 'perder' dar. Die Formen im Präsens Indikativ lauten:

-> yo pierdo
-> tu pierdes
-> el/ella pierde
-> nosotros perdemos
-> vosotros perdéis
-> ellos/ellas pierden

Die Regelvarianten müssen so aufgebaut werden, dass
1. jeweils der korrekte Artikel je Regelvariante vorangestellt wird,
2. die jeweils richtige Endung nach dem Verbstamm angefügt wird (Ersetzen ab
den letzten n Zeichen),

3. Für die 1., 2. 3. Singularform sowie für die 3. Pluralform das e im Verbstamm
durch ie ersetzt wird. Dies geschieht durch die 2. Möglichkeit zur Definition der
Regelvariante: "Ersetze die Zeichenfolge e innerhalb der ersten 4
Zeichen durch die Zeichenfolge ie."


word9fax

Ausgewählten Eintrag drucken

Mit Hilfe dieser Funktion im Menü 'Bearbeiten' oder durch Anklicken des zugehörigen Icons können Sie den aktuell ausgewählten Eintrag mit allen zugehörigen Informationen ausdrucken. Im Druckdialog können Sie auswählen, welche Informationen zum Eintrag ausgedruckt werden sollen.


word9fcg

Erstes Stichwort anlegen (Enzyklopädien)

1. Anschließend werden Sie aufgefordert ein erstes Stichwort einzutragen.
Hinweis: Seit Wordbook 2012r (Version 22) kann für Beschreibungen/Erläuterungen eine eigene Schriftart eingestellt werden. Da dieses Feld nun ebenfalls unicode-fähig ist, können nun auch fremdsprachige Zeichen (auch längere Texte) in dieses Feld eingegeben werden. Diese Möglichkeit kann z.B. zum Aufbau fremdsprachiger Lexika bzw. Enzyklopädien genutzt werden.
2. Optional können Sie eine Kurzbeschreibung für die Enzyklopädie eingeben (z.B. Lexikon seltener Pflanzen in Europa).
3. Klicken Sie zum Abschluß auf OK.

Als nächstes folgt:

4. Informationen zum Stichwort eingeben


word9fch

Historie

Mit Hilfe dieser Funktion können Sie sich die Historie der neu angelegten bzw. der geänderten Stichworte anzeigen lassen. Die Einträge werden nach absteigendem Erstellungs- bzw. Änderungsdatum sortiert aufgelistet. Durch Doppelklick können Sie direkt zum ausgewählten Stichwort springen.
So lassen sich z.B. die zuletzt geänderten bzw. die zuletzt neu angelegten Stichworte schnell auffinden. Über 'Historie löschen' kann die gesamte Historie gelöscht werden.


word9fcj

Erstes Stichwort anlegen (Weblog)

1. Anschließend werden Sie aufgefordert ein erstes Stichwort einzutragen. Als Voreinstellung wird das aktuelle Datum zusammen mit der Uhrzeit eingetragen. Diese Voreinstellung können Sie natürlich ändern. Sie sollten dabei aber bedenken, dass innerhalb des Datenbank-Typs "Weblog" in jedem Fall eine chronologische Reihenfolge der Einträge (Sortierung nach Anlegedatum) eingehalten wird. Das voreingestellte Datumsformat können Sie auch unter den Einstellungen ändern.
2. Optional können Sie eine Kurzbeschreibung für das Weblog eingeben.
3. Sehr wesentlich, gerade für Weblogs, sind die Einstellungen unter Publikationsziel für Web-Ausgabe und für die RSS-Feed-Ausgabe. Diese Angaben werden benötigt, wenn eine Datenbank in einem Internet-fähigen Format aufbereitet werden soll. Im Einzelnen sind hier anzugeben:

- Website-Adresse: Diese Adresse sollte der Web-Adresse entsprechen, auf die die Web-Ausgabe von Wordbook publiziert werden soll. Wichtig dabei ist, dass Wordbook sämtliche Pfadangaben entweder als absoluten Pfad oder als relativ zu dieser Adresse stehend behandelt. Somit wird sichergestellt, dass Web-Ressourcen (Bilder, Dateien, etc.) richtig aufgerufen werden können.

Beispiel: Sie erstellen eine Datenbank "MyWeblog.awb". Die Inhalte der Datenbank möchten Sie auf der Website "www.MyWebsite.de" publizieren. Als Web-Adresse geben Sie deshalb "HTTP://www.MyWebsite.de" an. Beachten Sie weiterhin, dass die von Wordbook verwalteten Dateien, Bilder, usw. in einem fest zur Datenbank gehörenden Ordner abgelegt werden. Dieser Ordner heisst immer so wie die Datenbank, d.h. in diesem Beispiel "MyWeblog". Wenn Sie nun eine Datenbank z.B. als HTML-Ausgabe oder RSS-Newsfeed ausgeben, dann wird diese Ausgabe zunächst unter einem frei wählbaren Dateinamen - z.B. MyWeblog1.HTM oder MyWeblog1.RSS gespeichert. Diese Datei (und alle generierten Folgedateien) müssen Sie anschließend auf ihre Webpräsenz übertragen (z.B. mit Hilfe eines FTP-Tools). Wichtig ist, dass der Ordner "MyWeblog" ebenfalls auf den Web-Server übertragen werden muss, damit die verwalteten Dateien, Bilder etc. im Web zur Verfügung stehen.

- Autor der Datenbank
- Copyright-Hinweis
- E-Mail-Adresse

Diese Informationen sind optional einzugeben. Sie werden bei der Ausgabe von Wordbook-Daten als RSS-Newsfeed verwendet.

4. Klicken Sie zum Abschluß auf OK.

Als nächstes folgt:

5. Informationen zum Stichwort eingeben - Dieser Schritt unterscheidet sich im Grunde nicht von der Vorgehensweise beim Erstellen von Enzyklopädien, d.h. Sie können auch bei Weblogs zu jedem Eintrag Text eingeben, Sachgebiete und Eigenschaften zuordnen, Dateien anhängen, Links und Querverweise erstellen, usw. Der einzige Unterschied besteht im vorgegebenen Zeitbezug des Stichworts (dieses ist jedoch änderbar) und der chronologischen Sortierung der Einträge.


word9fck

Bericht in RSS-Datei ausgeben

Diese sehr mächtige Funktion ermöglicht es Ihnen den Datenbankinhalt (oder den Inhalt mehrerer gleichzeitig geöffneter Datenbanken) als RSS-Newsfeed auszugeben. Als Format wird RSS 2.0 verwendet.
Im Unterschied zu HTML-Seiten bieten RSS-Seiten die Möglichkeit Inhalte zu "abonnieren". Es wird dann - je nach Einstellung - vom Feedreader-Programm jeweils nur auf die neu hinzugekommenen Inhalte hingewiesen. Zur Funktionsweise von RSS und Newsfeeds im Allgemeinen sei auf die entsprechende Literatur bzw. entsprechende Internet-Artikel (z.B. auch unter www.wikipedia.de) verwiesen.

Es kann entweder der gesamte Datenbankinhalt veröffentlicht werden oder aber nur bestimmte Abschnitte. Sie können Stichworte (Bemerkung, Links, ...) auswählen und Filter-Funktionen einsetzen. Beachten Sie, dass bestimmte Elemente von Wordbook derzeit (noch) nicht in das RSS-Format mit publiziert werden (z.B. Querverweise, Eigenschaften, Sachgebiete).

Die erstellte RSS-Datei wird von typischen Newsfeed-Readern erkannt und gelesen (u.a. auch vom Internet Explorer 7). Da sich mit Wordbook auch angehängte Dateien in verschiedensten Formaten als RSS-Newsfeed ausgeben lassen, sind somit vielfältige Anwendungen möglich. Z.B. können auch MP3-Dateien publiziert werden, so dass mit Wordbook auch das sogenannte "Podcasting" realisiert werden kann.


word9fcl

Eintrag im RSS-Format in die Zwischenablage kopieren

Diese Funktion kopiert den ausgewählten Eintrag im RSS-Feed-Format in die Windows-Zwischenablage. Damit steht der Eintrag zur weiteren Vearbeitung zur Verfügung und kann RSS-verarbeitenden Anwendungen zur Verfügung gestellt werden. Verweise auf Dateianhänge werden bei dieser Kopiermethode nicht mit in die Zwischenablage kopiert.


word9fcm

Eintrag im RSS-Format in die Zwischenablage kopieren (mit Dateiverweisen)

Diese Funktion kopiert den ausgewählten Eintrag im RSS-Feed-Format in die Windows-Zwischenablage. Damit steht der Eintrag zur weiteren Vearbeitung zur Verfügung und kann RSS-verarbeitenden Anwendungen zur Verfügung gestellt werden. Verweise auf Dateianhänge werden bei dieser Kopiermethode mit in die Zwischenablage kopiert.


BildUpload

Bilder importieren (Mehrfachauswahl)

Mit dieser Funktion können mehrere Bilder nach Wordbook importiert werden. Die Auswahl erfolgt über einen Dateiauswahl-Dialog
bei dem die einzelnen Bilder ausgewählt werden können (Strg & Mausklick oder Strg & A).
Für jedes importierte Bild wird automatisch ein neuer Eintrag angelegt.
Der Standardtext (Bild) kann je Importvorgang angepasst werden. Die Bilder werden automatisch durchnummeriert.
Zusätzlich können bei jedem Importvorgang Eigenschaften und/oder Sachgebiete ausgewählt werden, die automatisch zu jedem Bild hinzugefügt werden.
Die Funktion “Bilder importieren (Mehrfachauswahl)” eignet sich somit zur Kategorisierung von digitalen Bildbeständen, wie z.B. Fotosammlungen. Die je Importvorgang maximal hochzuladende Anzahl an Bildern ist begrenzt, wobei die Grenze von der Länge der Bild-Dateinamen abhängig ist. Der Import einer größeren Anzahl an Bildern kann zudem einige Zeit beanspruchen, da beim Import-Vorgang die Bilddateien in den Ordner der Wordbook-Datenbank kopiert werden und anschließend die Reporting-Tabellen aktualisiert werden.


DBKopieren

Datenbankkopie erstellen

Vor dem Sichern muß die aktuelle Datenbank geschlossen werden. Anschließend geben Sie ein Ziel (Pfad- und Dateinamen) für die Datenbank-Kopie an. Die Datenbank wird anschließend dorthin kopiert. Bilddateien, Audiodateien und sonstige Dateianhänge werden in einen separaten Ordner mitgesichert.


Dienstprogramme

Übersicht Dienstprogramme

Unter diesem Punkt werden mehrere Dienstprogramme zusammengefasst, um die Wordbook-Datenbank sowie die enthaltenen Daten zu pflegen.
Die folgenden Funktionen sind vorhanden:

  • Querverweise aufbauen/aktualisieren
  • Mehrfach vorhandene Einträge finden
  • Suchindex neu aufbauen
  • Report-Tabellen aktualisieren (Full Update)
  • Report-Tabellen aktualisieren (seit letzter Aktualisierung)
  • Sortierung neu aufbauen
  • Eigenschaften löschen
  • Sachgebiete löschen
  • Stichworte mit einer bestimmten Eigenschaft löschen
  • Stichworte mit einem bestimmten Sachgebiet löschen
  • Stichworte im Zeitraum von/bis löschen
  • Suchen und Ersetzen


FastEntry

Batch-Eingabe

Die Batch-Eingabe ermöglicht es, mehrere Stichworte mit jeweils bis zu drei zugehörigen Entsprechungen nacheinander einzugeben und die Eingaben anschließend in der Datenbank abzuspeichern. Die Batch-Eingabe eignet sich vor allem zur schnellen Eingabe von Stichwörtern. So kann schnell und einfach das Grundgerüst eines Wörterbuchs aufgebaut werden. Wenn ein Stichwort mehr als drei Entsprechungen hat oder wenn z.B. Beispiele hinzugefügt werden sollen, so ist der Standard-Eingabedialog zu verwenden. Die per Batch-Eingabe angelegten Stichwörter können natürlich auch nachträglich noch über die Standard-Eingabe bearbeitet und erweitert werden.
Es gibt bei der Batch-Eingabe die Möglichkeit, das Abspeichern bereits in der Datenbank vorhandener Stichwörter zu unterbinden. Eine andere Möglichkeit, um doppelt gespeicherte Stichwörter zu identifizieren und ggf. zusammenzuführen, findet sich unter Extras -> Dienstprogramme -> Mehrfach vorhandene Einträge finden.
Die Batch-Eingabe ist nur für Datenbanken vom Typ ‘Wörterbuch’ möglich.
.


Produktivität

Die Berichte zur Produktivität ermöglichen die Auswertung/Zählung der in einem bestimmten Zeitraum angelegten oder geänderten Stichwörter.
Die folgenden Auswertungen sind möglich:
- Wochentag
- Woche
- Monat
- Quartal
- Jahr
.


Replace

Suchen und Ersetzen

Die neue Funktion 'Suchen und Ersetzen' befindet sich im Programmmenü unter den Dienstprogrammen. Diese Funktion ermöglicht es, in einer Wordbook-Datenbank Ersetzungen durchzuführen. Die Ersetzungen werden für alle Fundstellen in der Datenbank durchgeführt. Sie können jeweils wählen, ob die Ersetzungen für

- Stichworte
- Bemerkungen
- Entsprechungen
- Beispiele
- Beispielübersetzungen

durchgeführt werden sollen.

Bei Datenbanken vom Typ “Lexikon/Enzyklopädie” oder “Weblog” können Fundstellen in

- URL-Namen
- URLs
- URL-Notizen

in der Datenbank ersetzt werden.

Wozu ist die neue Funktion nützlich? Beispielsweise ist es manchmal erforderlich eine systematische Änderung für viele Datenbankeinträge durchzuführen. Dies kann dann schnell und einfach mit Suchen und Ersetzen bewerkstelligt werden, anstatt jeden Datenbankeintrag einzeln aufzurufen, um die Änderung durchzuführen. Auch ist es manchmal erforderlich, die Schreibweise eines Begriffs innerhalb der gesamten Datenbank zu ändern. Oder eine URL innerhalb einer erstellten Linksammlung ändert sich und muss aktualisiert werden, usw.


seite56

Eigenschaften für Standardberichte

Die folgenden Einstellungen können für Standardberichte vorgenommen werden:

  • Einzug links
  • Abstand davor
  • Textbereichshöhe
  • Textbereichsbreite

Diese Einstellungen können für jedes einzelne Objekt vorgenommen werden (Stichworte, Eigenschaften u.a.). Die Angaben müssen jeweils in Millimeter erfolgen. Zusammen mit der Möglichkeit der Einstellung von Schriftarten für die Ausgabe, ermöglicht dies einen höheren Gestaltungsgrad der Standardberichte.


seite57

Report-Tabellen aktualisieren

Wordbook speichert die eingegebenen Daten für die Berichtsausgabe in speziell dafür vorgesehenen Tabellen ab. Diese Tabellen werden normalerweise automatisch aktuell gehalten. Mit Hilfe dieser Funktion können die Report-Tabellen aber bei Bedarf nochmals aktualisiert werden.

Es exisitieren 2 Versionen dieser Funktion:

  • Report-Tabellen aktualisieren (Full Update)
    Die Report-Tabellen der gesamten Datenbank werden aktualisiert. Dieser Vorgang kann bei umfangreichen Datenbanken längere Zeit dauern.
  • Report-Tabellen aktualisieren (seit letzter Aktualisierung)
    Hier werden lediglich die Einträge seit der letzten Aktualisierung zur Aktualisierung der Report-Tabellen herangezogen. Das Datum der letzten Aktualisierung ist gespeichert unter Extras - Einstellungen - Standardberichte. Dort kann das Aktualisierungsdatum auch individuell eingestellt werden.

.


seite59

Datenbank mit aktuellen Filter-Einstellungen speichern

Die Datenbank kann mit den aktuell ausgewählten Filter-Einstellungen als neue Datenbank gespeichert werden.

Bei Ausführung dieser Funktion wird die aktuell geöffnete Datenbank mit den aktuellen Filter-Einstellungen unter einem neuen Datenbanknamen gespeichert. Die neue Datenbank enthält nur die durch die Filtereinstellungen ausgewählten Einträge. Die aktuell geöffnete Datenbank bleibt unverändert.


Stichworte löschen

Stichworte mit bestimmten Eigenschaften/Sachgebieten löschen

Mit diesem Dienstprogramm können Stichworte, denen eine bestimmte Eigenschaft oder ein bestimmtes Sachgebiet zugeordnet ist, gelöscht werden. Auf diese Weise kann z.B. für Stichworte eine ‘Löschvormerkung’ gesetzt werden. Die Löschvormerkung kann standardmäßig als Eigenschaft zum jeweiligen Stichwort zugeordnet werden.


StichworteAusTextLesen

Stichworte aus Text übernehmen

Mit der Funktion “Stichwörter aus Text übernehmen” können Stichworte automatisiert aus einem Voll-Text (TXT-Datei) eingelesen werden. Der Text wird dabei automatisiert in Wörter (und Sätze) als Textbestandteile zerlegt. Optional kann auch die Häufigkeit des Vorkommens von Wörtern in einem Text automatisiert ermittelt werden.

Allgemeines:
Es können lediglich Dateien im TXT-Format eingelesen werden. Texte, die in einem anderen Format wie z.B. HTML, PDF, Word vorliegen, müssen deshalb zunächst im TXT-Format abgespeichert werden.
Grundsätzlich können auch fremdsprachige Texte verarbeitet werden. Die Speicherung im TXT-Format muss dann ggf. in Unicode-Kodierung erfolgen.
Die durch die Funktion ausgeführte Zerlegung eines Textes in Sätze und Wörter folgt einer bestimmten Logik. Selbstverständlich können dabei auch Ergebnisse auftreten, die nicht unbedingt erwünscht sind und deshalb Vor- oder Nacharbeiten erforderlich machen können. Beispielsweise werden Abkürzungen in der Regel fehlinterpretiert, da sie den Punkt als Satzende-Zeichen enthalten.

Die Stichwortübernahme kann wie folgt konfiguriert werden:

Stichwort-Vorkommen zählen
Die Häufigkeit des Vorkommens von Wörtern in einem angegebenen Text wird gezählt. Die Häufigkeit wird für jedes gefundene Stichwort in die Wordbook-Datenbank eingetragen.
Die Anzahl der Stichwort-Vorkommen wird als Eigenschaft zum Stichwort gespeichert.

Kontext/Satz der Fundstelle übernehmen
Wahlweise kann entweder der komplette Satz oder ein Kontext der Fundstelle des Stichworts in die Datenbank mit übernommen werden. Wird “Kontext” ausgewählt, so entscheidet die Angabe für die Anzahl der Zeichen des Fundstellen-Kontexts über die Länge des in die Datenbank zu übernehmenden Fundstellen-Kontexts.
Kontext bzw. Satz werden im Beschreibungs-/Erläuterungsfeld der Wordbook-Datenbank gespeichert.

Satz/Kontext nicht übernehmen
Es werden lediglich die einzelnen Wörter des Textes als Stichwörter in die Datenbank übernommen. Der Satz bzw. der Fundstellen-Kontext wird nicht übernommen.

Satzende-Zeichen
Standardmäßig sind Punkt, Ausrufezeichen und Fragezeichen als Satzende-Zeichen eingestellt. Das Satzende-Zeichen entscheidet darüber, ob ein Satz als solcher erkannt wird.

Kontext-Begrenzungszeichen
Die Begrenzungszeichen werden verwendet um Anfang und Ende eines Fundstellen-Kontexts optisch zu kennzeichnen.

Maximale Anzahl Fundstellen
Diese Einstellung gibt an, wieviele Fundstellen maximal als Satz oder Kontext in die Datenbank geschrieben werden sollen. Diese Einstellung ist vor allem wichtig für die Übernahme von Wörtern, die sehr häufig in einem Text vorkommen (z.B. Artikel, Präpositionen), um die Zahl der Fundstellen zu begrenzen.

Eigenschaften/Sachgebiete automatisch zuordnen
Wenn diese Einstellung aktiviert wird, lassen sich Eigenschaften und/oder Sachgebiete automatisch zu den aus dem Text übernommenen Stichworten zuweisen. So läßt sich beispielsweise für jedes Stichwort eine Information über die Textquelle mitgeben, indem eine entsprechende Eigenschaft oder ein Sachgebiet angelegt wird, das die Textquelle beschreibt.

Ausgabe-Ziel Kontext/Sätze:
Diese Einstellung ermöglicht es nun den Kontext der zu übernehmenden Stichworte bzw. ganze Sätze zu den Fundstellen entweder im Erläuterungsfeld oder als Entsprechungen zu speichern.

Die Aktualisierung der Report-Tabellen (für Stichworte) werden standardmäßig nach jeder Textübernahme aktualisiert. Über eine Checkbox kann eingestellt werden, dass die Aktualisierung der Report-Tabellen (für Stichworte) nicht erfolgen soll. In jedem Fall sollten aber nach Abschluss des Einlesens von Textdateien auch die Report-Tabellen (für Stichworte) aktualisiert werden. Dies kann zu jeder Zeit für die gesamte Datenbank über die Extras -> Übersicht Dienstprogramme erfolgen.
Es existiert außerdem ein Button, über den die aktuell zur Auto-Zuordnung eingestellten Eigenschaften/Sachgebiete überprüft bzw. eingestellt werden können.


StichwortLoeschen

Stichworte im Zeitraum von/bis löschen

Mit diesem Dienstprogramm können Stichworte, die in einem definierten Zeitraum angelegt oder geändert wurden, gelöscht werden.
Diese Funktion ist z.B. nützlich, wenn ein Datenimport durchgeführt wurde, der wieder rückgängig gemacht werden soll oder bei anderen Fällen, in denen Stichworte aus der Datenbank gelöscht werden sollen.
Wichtig ist es dabei, den Zeitraum, in dem die zu löschenden Stichworte angelegt/geändert wurden, korrekt einzuschränken. Dies ist mit Hilfe der Auswahlfelder sekundengenau möglich.
Eine Vorschau zeigt, welche Stichworte aufgrund der getätigten Auswahl gelöscht werden.


Umgebung

In den Umgebungs-Einstellungen sind Programme eingetragen, mit denen Dateianhänge aus Wordbook heraus geöffnet werden. Welches Programm zum Öffnen verwendet wird, hängt von der jeweiligen Dateiendung des Dateianhangs ab. Voreingestellt sind die Windows-Bild-Fax-Anzeige zum Öffnen von Bild-Dateien sowie der Windows-Media-Player zum Abspielen von angehängten Audio-Dateien.
Die eingetragenen Programme können geändert werden bzw. neue Einträge für weitere Datei-Typen hinzugefügt werden. So können Sie z.B. Ihren verwendeten PDF-Reader eintragen, um damit PDF-Anhänge zu öffnen.
Über ‘Zurücksetzen’ wird die angezeigte Tabelle auf die ursprünglichen Umgebungs-Einstellungen zurückgesetzt.